Closed Bug 1325141 Opened 3 years ago Closed 3 years ago

leak in browser/components/extensions/test/browser/test-oop-extensions directory on osx debug

Categories

(WebExtensions :: Untriaged, defect)

defect
Not set

Tracking

(firefox50 wontfix, firefox51+ fixed, firefox52+ fixed, firefox53+ fixed)

RESOLVED FIXED
mozilla53
Tracking Status
firefox50 --- wontfix
firefox51 + fixed
firefox52 + fixed
firefox53 + fixed

People

(Reporter: jmaher, Assigned: kmag)

References

Details

Attachments

(1 file)

we have not been reporting leaks as failures on treeherder lately, I see this leak showing up in the logs but treeherder reports a green status.

here is a log file from a recent m-c push:
https://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-central-macosx64-debug/1482335873/mozilla-central_yosemite_r7-debug_test-mochitest-e10s-browser-chrome-1-bm106-tests1-macosx-build1.txt.gz


and data from the bloat/leak log:
09:35:55     INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, default process 2342
09:35:55     INFO - 
09:35:55     INFO -      |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
09:35:55     INFO -      |                                      | Per-Inst   Leaked|   Total      Rem|
09:35:55     INFO -    0 |TOTAL                                 |       23     1104|103693888        4|
09:35:55     INFO -  891 |nsBaseWidget                          |      384      384|    1116        1|
09:35:55     INFO -  951 |nsCocoaWindow                         |      560      560|     363        1|
09:35:55     INFO - 1204 |nsMenuGroupOwnerX                     |      152      152|     224        1|
09:35:55     INFO - 1398 |nsTArray_base                         |        8        8|29318414        1|
09:35:55     INFO - 
09:35:55     INFO - nsTraceRefcnt::DumpStatistics: 1527 entries
09:35:55     INFO - TEST-INFO | leakcheck | default process: leaked 1 nsBaseWidget
09:35:55     INFO - TEST-INFO | leakcheck | default process: leaked 1 nsCocoaWindow
09:35:55     INFO - TEST-INFO | leakcheck | default process: leaked 1 nsMenuGroupOwnerX
09:35:55     INFO - TEST-INFO | leakcheck | default process: leaked 1 nsTArray_base
09:35:55  WARNING - TEST-UNEXPECTED-FAIL | leakcheck | default process: 1104 bytes leaked (nsBaseWidget, nsCocoaWindow, nsMenuGroupOwnerX, nsTArray_base)
09:35:55     INFO - 
09:35:55     INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 2343
09:35:55     INFO - 
09:35:55     INFO -      |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
09:35:55     INFO -      |                                      | Per-Inst   Leaked|   Total      Rem|
09:35:55     INFO -    0 |TOTAL                                 |       27        0|18318412        0|
09:35:55     INFO - 
09:35:55     INFO - nsTraceRefcnt::DumpStatistics: 956 entries
09:35:55     INFO -
[Tracking Requested - why for this release]: Leaks are bad.
Attachment #8822791 - Flags: review?(enndeakin)
Assignee: nobody → kmaglione+bmo
Comment on attachment 8822791 [details]
Bug 1325141: Fix leak in Z-constrained windows on OS-X.

https://reviewboard.mozilla.org/r/101572/#review102100

thanks for tackling this leak!  The whitelist changes look great- I am excited that you are doing those as well
Attachment #8822791 - Flags: review?(jmaher) → review+
Comment on attachment 8822791 [details]
Bug 1325141: Fix leak in Z-constrained windows on OS-X.

https://reviewboard.mozilla.org/r/101572/#review102114
Attachment #8822791 - Flags: review?(enndeakin) → review+
Tracking 51/52/53+ for the reasons in Comment 1.
https://hg.mozilla.org/mozilla-central/rev/65717a8b052b
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
AFAICT, this one only affected trunk (the Aurora version of the patch from bug 1325148 didn't have a whitelist entry for it), but feel free to set other branches to affected and request uplift if I got that wrong.
All branches are affected by the leak. The whitelist and the tests that triggered it are only in 53.
Comment on attachment 8822791 [details]
Bug 1325141: Fix leak in Z-constrained windows on OS-X.

Approval Request Comment
[Feature/Bug causing the regression]: N/A
[User impact if declined]: This bug causes leaks on OS-X whenever alwaysRaised or alwaysLowered windows are used on OS-X.
[Is this code covered by automated tests?]: Yes.
[Has the fix been verified in Nightly?]: No.
[Needs manual test from QE? If yes, steps to reproduce]: No, the leak checks in the test suite are sufficient.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No, it is very low risk.
[Why is the change risky/not risky?]: This change simply fixes a minor reference counting issue by replacing a bare pointer with a smart pointer.
[String changes made/needed]: None.
Attachment #8822791 - Flags: approval-mozilla-beta?
Attachment #8822791 - Flags: approval-mozilla-aurora?
Comment on attachment 8822791 [details]
Bug 1325141: Fix leak in Z-constrained windows on OS-X.

Fix for memory leak, sounds good to me!
Attachment #8822791 - Flags: approval-mozilla-beta?
Attachment #8822791 - Flags: approval-mozilla-beta+
Attachment #8822791 - Flags: approval-mozilla-aurora?
Attachment #8822791 - Flags: approval-mozilla-aurora+
needs rebasing for aurora
Flags: needinfo?(kmaglione+bmo)
The conflict was in runtests.py, which can be safely disregarded per comment 8.
Flags: needinfo?(kmaglione+bmo)
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.