Assertion failure: false (We should be reviving the graph?) @ mozilla::MediaStreamGraph::ApplyAudioContextOperation

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: MediaStreamGraph
P2
normal
Rank:
25
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: bc, Assigned: padenot)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8820893 [details]
Null ptr Crash report for https://meet.jit.si/TartinesCongres

1. https://meet.jit.si/TartinesCongres in Beta/51, Aurora/52, Nightly/53 debug build on Linux

2. shutdown browser

Null ptr Crash [@ mozilla::MediaStreamGraph::ApplyAudioContextOperation(mozilla::MediaStream*, nsTArray<mozilla::MediaStream*> const&, mozilla::dom::AudioContextOperation, void*)::AudioContextOperationControlMessage::RunDuringShutdown()]

I also see 
Assertion failure: false (We should be reviving the graph?), at /mozilla/builds/nightly/mozilla/dom/media/MediaStreamGraph.cpp:3939 but can not reproduce this with locally produced builds on Fedora 24 though Bughunter can reproduce it non reliably with tinderbox builds with a number of urls.

I'll attach the stack and log from an example run for the assertion. This might be related to bug 1157986 since the bughunter vms don't have real hardware.
(Reporter)

Comment 1

2 years ago
Created attachment 8820894 [details]
assertion Crash Report
(Reporter)

Comment 2

2 years ago
Created attachment 8820895 [details]
assertion log

Updated

2 years ago
Rank: 25
Priority: -- → P2
(Assignee)

Updated

2 years ago
Assignee: nobody → padenot
(Assignee)

Comment 3

2 years ago
I haven't been able to repro this, tried when this was filed, and again just now. Maybe it could have been caused by bug 1228226, that we backed out recently.

If someone can repro, please reopen with more details.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.