Handle the [...].forEach((...) => XPCOMUtils.defineLazyModuleGetter(...)) form of getters when detecting globals

RESOLVED DUPLICATE of bug 1388215

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 1388215
2 years ago
4 months ago

People

(Reporter: standard8, Unassigned)

Tracking

3 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Currently, our import rules don't handle this form of import:

[
  ["AboutHome", "resource:///modules/AboutHome.jsm"],
].forEach(([name, resource]) => XPCOMUtils.defineLazyModuleGetter(this, name, resource));

There's a couple of places we use this currently - in browser.js and nsBrowserGlue.js. It would make our lives simpler if we could get the rules handling the globals to detect these.
(Reporter)

Updated

2 years ago
Priority: -- → P2
(Reporter)

Comment 1

2 years ago
Thanks to Kit, this has been fixed in bug 1388215 :-)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1388215

Updated

a year ago
Product: Testing → Firefox Build System
Version: Version 3 → 3 Branch
You need to log in before you can comment on or make changes to this bug.