X primary selection clobbered with "about:home" when focusing the location bar of a new window

RESOLVED FIXED in Firefox 52

Status

()

P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: heycam, Assigned: heycam)

Tracking

({regression})

47 Branch
Firefox 53
All
Linux
regression
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox50 wontfix, firefox51 wontfix, firefox52 fixed, firefox53 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
STR:

1. Have about:home set as your homepage.
2. Select some text in any program, to put it into the X primary selection.
3. Switch to Firefox (if that text you selected was in some other program).
4. Press Ctrl+N, see that the focus is in the about:home's search box in the middle of the page.
5. Press Ctrl+L to focus the location bar.
6. Middle click in the location bar, and see that it pastes "about:home" rather than the text that you selected in step 2.
(Assignee)

Comment 1

2 years ago
Note that if you skip step 5, and middle click on the location bar before it is focused, the correct text is pasted.
(Assignee)

Updated

2 years ago
Summary: X primary selection clobbered with "about:home" when focusing the location bar of a new tab/window → X primary selection clobbered with "about:home" when focusing the location bar of a new window
(Assignee)

Comment 2

2 years ago
Karl, do you know whose attention this could be brought to?
Flags: needinfo?(karlt)
The selection is clobbered during step 5 ("watch -n 1 xsel" is helpful).

The same bug occurs if focus is elsewhere, e.g. in the chrome search box,
before moving focus to the location bar.

The bug does not occur when moving focus with mouse click.

The bug does occur when moving focus from the chrome search box with
Shift+Tab.

The bug does not occur with about:newtab.

Happens with and without e10s.

Bad bug for those who use the keyboard to move focus.
Workaround is to use about:newtab for home.
Priority: -- → P2
Prior to Firefox 50, this does not reproduce when moving focus from the about:home page search box to the location bar, but does reproduce when moving focus from the chrome search box to the location bar.  These STR are useful for finding the earlier regression.

1. Have about:home set as your homepage.
2. Select some text in any program, to put it into the X primary selection.
3. Start Firefox.  See that the focus is in the about:home's search box in the middle of the page.
4. Focus the search bar, with a mouse click or otherwise.
5. Press Ctrl+L to focus the location bar.
6. Middle click in the location bar, and see that it pastes "about:home" rather than the text that you selected in step 2.

46.0b11 is good.
47.0b3 is bad.

(In reply to Cameron McCormack (:heycam) from comment #2)
> Karl, do you know whose attention this could be brought to?

I assume there are people to triage regressions, and so the keyword should be sufficient.  A regression window should finger the right person.
status-firefox50: --- → affected
status-firefox53: --- → affected
status-firefox-esr45: --- → unaffected
Flags: needinfo?(karlt)
Keywords: regression, regressionwindow-wanted
Version: unspecified → 47 Branch
(Assignee)

Comment 5

2 years ago
10:21.12 INFO: Last good revision: 81ab1a659071fb4b99852b1c611b341557f21ca4
10:21.12 INFO: First bad revision: 8033efa33b55d559f6d8735f4d404435b3fbf57e
10:21.12 INFO: Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=81ab1a659071fb4b99852b1c611b341557f21ca4&tochange=8033efa33b55d559f6d8735f4d404435b3fbf57e
10:21.85 INFO: Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=824887
Blocks: 824887
Keywords: regressionwindow-wanted
Comment hidden (mozreview-request)

Comment 7

2 years ago
mozreview-review
Comment on attachment 8825304 [details]
Bug 1325535 - Don't copy the hidden about:home URL from the location bar when focusing it.

https://reviewboard.mozilla.org/r/103482/#review104124
Attachment #8825304 - Flags: review?(dao+bmo) → review+

Comment 8

2 years ago
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/53858983e93a
Don't copy the hidden about:home URL from the location bar when focusing it. r=dao

Updated

2 years ago
Assignee: nobody → cam

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/53858983e93a
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox53: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
QA Contact: cristian.comorasu
Please request Aurora approval on this when you get a chance. Not sure this is worth uplifting to Beta given that we're spinning the release candidate next week, but feel free to nominate if you think it is.
status-firefox50: affected → wontfix
status-firefox51: --- → affected
status-firefox52: --- → affected
Flags: needinfo?(cam)
(Assignee)

Comment 11

2 years ago
Comment on attachment 8825304 [details]
Bug 1325535 - Don't copy the hidden about:home URL from the location bar when focusing it.

Approval Request Comment
[Feature/Bug causing the regression]: bug 824887
[User impact if declined]: clipboard clobber for Linux users after performing specific sequence of UI interactions
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: very localized change
[String changes made/needed]: none
Flags: needinfo?(cam)
Attachment #8825304 - Flags: approval-mozilla-aurora?
Comment on attachment 8825304 [details]
Bug 1325535 - Don't copy the hidden about:home URL from the location bar when focusing it.

avoid selection clobber when focusing the location bar, aurora52+
Attachment #8825304 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 13

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/41e715615d9c
status-firefox52: affected → fixed
Too late for 51. Mark 51 won't fix.
status-firefox51: affected → wontfix
Based on comment 11, I will remove myself from QA contact, if this does indeed need qa manual please feel free to request this with QE-verify + and needinfo me. Thank you!
Flags: qe-verify-
QA Contact: cristian.comorasu
You need to log in before you can comment on or make changes to this bug.