Disable Windows a11y+e10s in 52

VERIFIED FIXED

Status

()

Core
Disability Access APIs
VERIFIED FIXED
6 months ago
5 months ago

People

(Reporter: aklotz, Assigned: aklotz)

Tracking

52 Branch
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(firefox51 disabled, firefox52 verified, firefox53 unaffected)

Details

Attachments

(3 attachments)

a11y+e10s has been bumped to 53.
Depends on: 1310788
status-firefox51: --- → disabled
status-firefox52: --- → affected
status-firefox53: --- → unaffected
Created attachment 8822245 [details] [diff] [review]
Restore Windows a11y checks for e10s
Attachment #8822245 - Flags: review?(jmathies)
Created attachment 8822246 [details] [diff] [review]
Modify ContentParent to only initialize a11y on Windows when e10s is force-enabled
Attachment #8822246 - Flags: review?(jmathies)
Created attachment 8822248 [details] [diff] [review]
Restore Windows check to "a11y disables e10s" prompt
Attachment #8822248 - Flags: review?(mconley)

Comment 4

6 months ago
Comment on attachment 8822245 [details] [diff] [review]
Restore Windows a11y checks for e10s

Review of attachment 8822245 [details] [diff] [review]:
-----------------------------------------------------------------

Please make sure and test this in an aurora build to be sure it's working as expected.
Attachment #8822245 - Flags: review?(jmathies) → review+

Comment 5

6 months ago
Comment on attachment 8822246 [details] [diff] [review]
Modify ContentParent to only initialize a11y on Windows when e10s is force-enabled

Review of attachment 8822246 [details] [diff] [review]:
-----------------------------------------------------------------

r+ for aurora only landing
Attachment #8822246 - Flags: review?(jmathies) → review+
Comment on attachment 8822248 [details] [diff] [review]
Restore Windows check to "a11y disables e10s" prompt

Review of attachment 8822248 [details] [diff] [review]:
-----------------------------------------------------------------

Looks like a straight-forward backout of bug 1310788 for Aurora. r=me. Thanks aklotz!
Attachment #8822248 - Flags: review?(mconley) → review+
https://treeherder.mozilla.org/#/jobs?repo=try&revision=28d4c12745de
Comment on attachment 8822245 [details] [diff] [review]
Restore Windows a11y checks for e10s

Approval Request Comment
[Feature/Bug causing the regression]: a11y on e10s
[User impact if declined]: This feature is not ready to ship in 52.
[Is this code covered by automated tests?]: Yes.
[Has the fix been verified in Nightly?]: No. This is a direct landing to Aurora.
[Needs manual test from QE? If yes, steps to reproduce]: Yes.
Case 1: Start 52 normally and verify that 52 starts with e10s enabled in about:support.
Case 2: Start 52 with NVDA running in the background. When it starts, verify in about:support that e10s is disabled due to a11y tools.
[List of other uplifts needed for the feature/fix]: All patches in this bug
[Is the change risky?]: No
[Why is the change risky/not risky?]: This change is essentially a backout of bug 1310788 that restores 52's behavior to the same behavior that already exists on 51 Beta and 50 Release. 
[String changes made/needed]: None
Attachment #8822245 - Flags: approval-mozilla-aurora?
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f82df8fc752f
Comment on attachment 8822245 [details] [diff] [review]
Restore Windows a11y checks for e10s

disable e10s with a11y for 52
Attachment #8822245 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8822248 - Flags: approval-mozilla-aurora+
Attachment #8822246 - Flags: approval-mozilla-aurora+
Flagging for QE.  Verification steps are in comment 8.
Flags: qe-verify+
https://hg.mozilla.org/releases/mozilla-aurora/rev/5ae057f09650
https://hg.mozilla.org/releases/mozilla-aurora/rev/cbe22ece71ee
https://hg.mozilla.org/releases/mozilla-aurora/rev/d55578d9c7de
status-firefox52: affected → fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Checked that Firefox 52 beta 1 starts with e10s enabled by default on Win 10 64-bit.

When NVDA is running in the background, 52 beta 1 opens with e10s enabled on the clean profile. After restarting, e10s is disabled by accessibility tools.
"Multiprocess Windows 	0/1 (Disabled by accessibility tools)"
Status: RESOLVED → VERIFIED
status-firefox52: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.