The text does not appear inside the button with HWA enabled

RESOLVED FIXED in Firefox 53

Status

()

defect
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: over68, Assigned: u459114)

Tracking

({regression})

53 Branch
mozilla53
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

3 years ago
strtestcase
Steps to reproduce:

1. Enable hardware acceleration.
2. Restart Firefox.
3. Go to https://dl.dropboxusercontent.com/u/95157096/85f61cf7/2gedjoqbn0.htm.

Test case: https://bugzilla.mozilla.org/attachment.cgi?id=8821412


Actual results:

The text does not appear inside the button.

Screenshot https://dl.dropboxusercontent.com/u/95157096/85f61cf7/wnaqb0tiwd.png
Reporter

Comment 2

3 years ago
This similar to bug 1322341.
Assignee

Updated

3 years ago
Assignee: nobody → cku
Flags: needinfo?(cku)
Assignee

Comment 3

3 years ago
hi blinky, just want to double confirm. When you said "Enable hardware acceleration" is that means to set "layers.acceleration.disabled" as false?
Flags: needinfo?(over68)
Reporter

Comment 4

3 years ago
(In reply to C.J. Ku[:cjku](UTC+8) from comment #3)
> hi blinky, just want to double confirm. When you said "Enable hardware
> acceleration" is that means to set "layers.acceleration.disabled" as false?

Yes, I mean to set "layers.acceleration.disabled" as false.
Flags: needinfo?(over68)

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment hidden (mozreview-request)
Assignee

Updated

3 years ago
Attachment #8822053 - Flags: review?(mstange)

Comment 6

3 years ago
mozreview-review
Comment on attachment 8822053 [details]
Bug 1325849 - Return LAYER_ACTIVE if AGR of a child change.

https://reviewboard.mozilla.org/r/101106/#review101606
Attachment #8822053 - Flags: review?(mstange) → review+

Updated

3 years ago
Blocks: 1325944

Updated

3 years ago
Component: Layout → Layout: Web Painting
Tracking 53+ for this text regression, which we should definitely try to fix.
It would be good to have a test.
Assignee

Comment 9

3 years ago
Since I had rollback the change in bug 1325550, this change does not exist anymore. Instead, I should go back to fix bug 1318266 and bug 1322341.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
No longer blocks: 1325944
Assignee

Updated

3 years ago
Target Milestone: --- → mozilla53
QA Whiteboard: [good first verify]
I have reproduced this bug with Firefox nightly 53.0a1 (build id:20161226030205)on
windows 7(64 bit)

I have verified this bug as fixed with Firefox beta 53.0b8(build id:20170330120906)
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

[testday-20170331]
I have reproduced this bug with Nightly 53.0a1 on Ubuntu 16.04.2 LTS - 64 Bit!

This bug's fix is verified wit latest Beta!

Build   ID : 20170330190824
User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0

[testday-20170331]
You need to log in before you can comment on or make changes to this bug.