Closed Bug 132606 Opened 19 years ago Closed 19 years ago

bad HTML source for POST request

Categories

(SeaMonkey :: UI Design, defect)

x86
Windows NT
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 55583

People

(Reporter: vladimir, Assigned: samir_bugzilla)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

When I try to look at the HTML source for a page that was the result from a POST
request, I don't get what I see. The problem is that Mozilla seems to just hit
the URL that I am on and display what it gets. It doesn't supply the POST
parameters when it hits the URL. The thing is that if I wanted to refresh a page
that is a result of a POST request, I will be prompted whether I wanted to
repost the data, but when I want to look at the HTML source I don't get
prompted. And by looking at the HTML source, it seems that the the POST
parameters weren't reposted. This works in Netscape 4.73 on NT.

Georgy.

Reproducible: Always
Steps to Reproduce:
1. go to a page that has a form with the POST method
2. fill in the form and submit it
3. try to look at the HTML source for the page that you are at (the result page)


Actual Results:  the HTML source is not what you see on the result page
dupe of bug #55583 ?
Yep.  #1 most-reported bug; first one in the list at
http://bugzilla.mozilla.org/duplicates.cgi

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.