dconf-CRITICAL on Generic Nightly

UNCONFIRMED
Unassigned

Status

()

UNCONFIRMED
2 years ago
11 months ago

People

(Reporter: jylo06g, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53 affected)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20161226030205

Steps to reproduce:

Fedora 25 x64
Download a fresh copy of Generic Nightly x64 from https://nightly.mozilla.org

Unpack and run from console...
Then first run or open Google.com (or certain websites), console outputs this error.

Here's other stuffs I did that doesn't work...
sudo
sudo -i
unset XDG_RUNTIME_DIR
chown -R <user> /run/user/1000
su


Actual results:

Console outputs the same error 3 times when going to Google.com (or other certain websites)...

(some_directory_to_bin:firefox_PID): dconf-CRITICAL **: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.


Expected results:

Shouldn't have this problem...?
It doesn't affect day to day usage (unless you are a clean freak over a console), but this doesn't seem to happen on Fedora's release of stable Firefox.
I also tried other Generic releases, Stable, Beta and Dev.
All of them do not have this issue.

Can't really find the same kind of bug in Bugzilla... Nightly only?
Could you try $ export XDG_RUNTIME_DIR=/run/user/1000 and see if the issue is still reproducible ?

I found a some Fedora issues related to the above reported behavior: 
https://bugzilla.redhat.com/show_bug.cgi?id=921689
https://bugzilla.redhat.com/show_bug.cgi?id=1296778

Do you by any chance run Mate? Although, what puzzles me at this point is that the problem arises only on Nightly and it is not reproducible on other channels. I will try to try to reproduce this issue a bit later on Fedora 23. (don't have a later version at this point)
Flags: needinfo?(jylo06g)
(Reporter)

Comment 2

2 years ago
Sorry, late reply...

I believe that the default is already set to XDG_RUNTIME_DIR=/run/user/1000 as env reports so...

I was on Cinnamon spin by the way, but I tried on MATE Compiz spin too. Same problem.

Not exactly how that will help (and the RH bugs) since pretty much other channels don't have this problem.
Flags: needinfo?(jylo06g)
(In reply to Jia Yuan Lo from comment #2)
> Not exactly how that will help (and the RH bugs) since pretty much other
> channels don't have this problem.
I was just trying to advance this bug. It does appear that this bug might've been introduced recently since it reproduces only on Nightly, although I have no ideas at this point concerning what introduced it. Let's assign a component for this bug, maybe somebody else has a better understanding of this.
status-firefox50: --- → unaffected
status-firefox51: --- → unaffected
status-firefox52: --- → unaffected
status-firefox53: --- → affected
Component: Untriaged → Shell Integration
You need to log in before you can comment on or make changes to this bug.