Printing any mail does not work anymore

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: marcus, Assigned: rods)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:0.9.9+)
Gecko/20020321
BuildID:    2002032117

Printing any mail does not work. When I try to print a mail, the message
"Loading message to print" appears in the status bar, and thats it.

Reproducible: Always
Steps to Reproduce:
1. Open a mail
2. try to print mail


Actual Results:  Message "Loading message to print" appears in the status bar,
and thats it. Mail will not be printed, print dialog does not appear.

Expected Results:  Print dialog should appear and mail should be printed

Comment 1

17 years ago
2002032117 on WinNT SP 6

i got a:

The Browser cannot print rightnow
Please try again when the page has finished loading

Comment 2

17 years ago
WFM W2K 2002031104, but confirming as per comment 1
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
This should be related to Bug 131174
http://bugzilla.mozilla.org/show_bug.cgi?id=131174

Comment 4

17 years ago
I have this bug too with Windows XP. Pretty annoying !

Comment 5

17 years ago
See comments 49 and 50 from bug 123554 also.

Comment 6

17 years ago
is this related to the bug you were talking about, the multiple print jobs from
mail?
Assignee: dcone → rods

Comment 7

17 years ago
With builds on 3-18 on winxp I could launch the app, print the home page from
the browser, then print a mail message and exit.  Both printed fine.  With the
3-21 build winxp, going through those same steps I get what the original
scenario gets.  Note: bug 131174 was logged for the 3-10 build and was a crash
when cancelling the print dialog.  Bug 123554 mentions that the fix for 131174
could have caused this bug.  Will test with 3-22 build since that fix was backed
out on 3-21.   Note, this is a general Print bug not just a MailNews bug ccing sujay
(Assignee)

Comment 8

17 years ago
Fixed I backed out a patch for a different bug that fixed this.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
This works now with the 3-22 win build.  Verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

17 years ago
This is not really fixed: When I print the first mail, everything is fine. But:
if you cancel printing a mail, any other mail you want to print after that will
just show the "Loading message to print" message in the status bar and that's
it. You have to exit Mozilla if you want to print another mail. Tested with
latest build 2002032732.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 11

17 years ago
Maybe this depends on the printer used? With HP Laserjet 4000TN and Windows 2000
over network I get the bug, with HP Deskjet 840C via USB on my Windows XP
machine it's all fine. Latest build of today!
(Assignee)

Comment 12

17 years ago
There was a problem but this should be fixed now. 
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
Marcus, please verify again in today's builds...mark this verified-fixed
if it works...thanks...

Comment 14

17 years ago
Using build 20020327 on winxp, linux, mac 10.1 this is fixed. Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.