Specific styling causes graphic corruption when I scroll fake scrollbar on https://vk.com/ with HWA disabled

NEW
Unassigned

Status

()

Core
Graphics
P3
normal
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned, NeedInfo)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 50, 32bit, ID 20160726080520 (2016-07-26)
STR_1:
0. Make sure DPI is set to 1.0
1. Restart Firefox with add-ons Disabled
1. Open attached "testcase 1"
2. Scroll the page so that iframe "widget_community.htm" is fully visible
3. Move mouse to the center of that iframe, rotate mouse wheel down, then scroll the page down
   by one page, then up by one page (via mouse wheel)

AR:  A dark-blue line appears at the right side of scrollbar
ER:  No extra blue lines

Notes:
1) If you can't reproduce, I recommend to test this on "Jeff' machine" mentioned in bug 1287066
2) Apparently the root case is bug 1147673, so everything done in bug 1289829 may be useless

This is regression from bug 1147673. Regression range:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2ec54b38a33da939a8255612999d9e867eb11664&tochange=bb5becd378f40a9be14e4e635d7034f2835fc7b5
(Reporter)

Updated

2 years ago
No longer blocks: 1277113
(Reporter)

Updated

2 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
(Reporter)

Comment 1

2 years ago
Created attachment 8822978 [details]
testcase 1 - bug 1327329.zip
From comment 0, the regression is from bug 1147673.
Flags: needinfo?(mstange)
Priority: -- → P3
Whiteboard: [gfx-noted]
You need to log in before you can comment on or make changes to this bug.