Mozregression GUI somehow can't subtract date from buildID during bisection

NEW
Unassigned

Status

Testing
mozregression
a year ago
a year ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
>>>   My Info:   Mozregression GUI version 0.9.2
STR_1:
1. Launch Mozregression GUI, click "File" -> "Run a new bisection"
2. Set Application -> "Firefox",  Bits -> 32, Build Type -> opt
3. Click Next twice
4. Set "Last known good build" -> buildID 20160313030418. Set "First known bad build" -> 2016-05-26
5. Click Finish
6. When the first build shows up, mark it as "Good"

AR:  Error dialog (see below) appears. When I close it, bisection stops
ER:  Either X or X+Y
 X) Application should bisect further
 Y) No error dialog


----Error:
platform: Windows-7-6.1.7601-SP1
python: 2.7.11 FROZEN (32bit)
mozregui: 0.9.2
mozregression: 2.3.2
message: TypeError: unsupported operand type(s) for -: 'datetime.date' and 'datetime.datetime'
traceback:   File ".\mozregui\bisection.py", line 193, in _evaluate_finished
  File "..\mozregression\bisector.py", line 514, in handle_verdict
  File "..\mozregression\bisector.py", line 114, in build_good
  File "..\mozregression\bisector.py", line 163, in _print_progress
(Reporter)

Updated

a year ago
No longer blocks: 1277113
(Reporter)

Updated

a year ago
Component: Untriaged → mozregression
Product: Firefox → Testing
You need to log in before you can comment on or make changes to this bug.