Closed Bug 1327631 Opened 8 years ago Closed 8 years ago

Tab displays "Connecting" instead of real title and can't be stopped by Escape after move to new window

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: arni2033, Unassigned)

References

Details

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open url [1] in a new tab 
2. In less than 10 seconds, move that tab to new window, then press Escape

> [1] data:text/html,<title>hello world</title><iframe src="http://briangrinstead.com/files/sleepy.php">

AR:  Tab displays "Connecting" instead of real title and can't be stopped by Escape key
ER:  Tab should displays real title. Escape key should cancel loading

Notes:
1) Originally I encountered it with a number of sites with ads that were loading infinitely
2) If you ask Brian Grinstead to greatly increase delay on that php page, you'll observe how tab NEVER
   gets back its real title. It's a real annoyance on the web.
No longer blocks: 1277113
See Also: → 1234240
Cannot reproduce with the following specs:
Mozilla/5.0 (Windows NT 6.1; rv:54.0) Gecko/20100101 Firefox/54.0
Status: NEW → RESOLVED
Closed: 8 years ago
Component: Untriaged → Tabbed Browser
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.