Need pref to disable download manager completely

VERIFIED INVALID

Status

SeaMonkey
Download & File Handling
VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: Kevin Wade, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I would like to turn off the download manager and use the old method of
downloading, which worked very well for me.  A pref to 'enable' or 'disable'
would do nicely.  This is all assuming the old stuff is still in the build
somewhere.
Duplicate of "Download Manager pref panel no longer visible"

*** This bug has been marked as a duplicate of 132440 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
This is *NOT* a duplicate of bug 132440.  That bug deals only with the UI front
end.  (The download manager is not disabled, only hidden from view.)

This bug is to DISABLE the new download manager altogether. (Not just hide it.)

Kevin: Can you re-open (remove duplicate status) and give any more needed
clarification?
(Reporter)

Comment 3

17 years ago
As stated by jasonb, this is not a duplicate.  Bug 132440 is about the pref
panel to choose type of window displayed by download manager.  This one is to
turn download manager completely off.  Reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
This _is_ a dup. The UI in question will let you either use the old style
progless dialogs, or the dlmgr, or neither.

If I misunderstood, please correct me and I'll reopen it. Thanks.

*** This bug has been marked as a duplicate of 132440 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
No, it only changes the interface that you see on the screen.  The download
manager is still working in the background.  I'm not sure why this is so
difficult to understand.

No matter what you "see" when you download (the download manager window, a
session progress window, or nothing at all) - it is STILL being download by the
download manager.  Once you've received your file you can verify this.  Go to
Tasks -> Tools -> Download Manager.  You'll see the download in the list that
its downloaded.

What this pref is about is disabling the code for the download manager downloads
themselves, NOT for what you visibly see.  We want the option of not having that
code be utilised (the download process code) at all.

Kevin: Back to you again. <grin>
(Reporter)

Comment 6

17 years ago
Perhaps folks should carefully read the comments before resolving bugs as
duplicates.  We've already been here on 3/22.  Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
In that case this bug is invalid, as the download manager *doesn't* download
anything itself. The download is performed by the network library. The download
manager is *only* about UI. Nothing has changed regarding what code actually
performs the download.

If I misunderstood again, please correct me and I'll reopen it. Thanks.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
(Note: If the bug is simply that you don't want old downloads appearing in the
download manager, then this is a duplicate of bug 132755.)

Comment 9

17 years ago
Please explain, then, what changed within the last few months.  Are you saying
that the "download manager" is nothing more, or less, than a windows listing
downloads and their progress - that this is merely front end window dressing to
what has always existed?

Correct me if I'm wrong, but didn't the introduction of the download manager
bring into play new code (Changes to the network library?) that caused some
instability?  If not, if nothing about the back end code changed around the time
that the UI for the download manager appeared, then I apologise for arguing for
this.
(Reporter)

Comment 10

17 years ago
RE comment #9:
Ditto.
If download manager is only ui then bug 132755 will satisfy my concerns.
Yes, download manager is pure UI.

If you have found instabilities in the network code, please get a talkback build
and file talkback reports.

(Even if the download manager had included network code and that network code
_did_ include instabilities, mind you, that would not be a reason to include a
pref to switch to the old code -- we would instead need to fix the new code.)
mass-verification of Invalid bugs.

if you don't think the report is invalid, please check to see if it has already
been reported (it might be a duplicate instead). otherwise, make sure that there
are steps (a valid test case) that clearly display the issue as an unexpected
defect.

mail filter string for bugspam: SequoiadendronGiganteum
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.