Shortcuts for changing zoom level don't work in browser toolbox and laggy in normal toolbox

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
2 years ago
3 months ago

People

(Reporter: arni2033, Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open devtools -> options, enable remote and chrome debugging, close devtools
2. Open browser toolbox
3. Switch to firefox window and back
4. Press Ctrl+"=", then Ctrl+0, then Ctrl+"-"

AR:  No visible action
ER:  Zoom level should change to work around that blurry UI impleented between Firefox 24 and 28


STR_2:
1. Open web console
2. Press Ctrl+"=", then Ctrl+"-", then Ctrl+0

AR:  Zoom is increased twice when I press Ctrl+"="
ER:  Zoom should be increased once when I press Ctrl+"="


This is regression from bug 1268450. Regression range:
> https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=fef64183cb939b13fbfdd5b1b44bd3c63d64d88f&tochange=df627da479f868c9704d7ac0b1c6aa76fb298150@ Alexandre Poirot [:ochameau]:
It seems that this is a regresion caused by your change. Please have a look.
(Reporter)

Updated

2 years ago
No longer blocks: 1277113
(Reporter)

Updated

2 years ago
Component: Untriaged → Developer Tools
Alex, how do you think this one should be prioritized?
Flags: needinfo?(poirot.alex)
I'm not able to reproduce first STR (do you reproduce?)
but I do reproduce the second which sounds like a P2.
Flags: needinfo?(poirot.alex)
Priority: -- → P2
No, I couldn't reproduce STR 1, mostly since I am not sure what "work around blurry UI" means.

Updated

9 months ago
Product: Firefox → DevTools
I can't reproduce either and it has been 2 years without activity on this bug. I'm going to close it. If anyone has reasons to believe this still happens and a clearer set of steps, then they should feel free to re-open it.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.