Jira does not work in recent nightlies

RESOLVED DUPLICATE of bug 1328218

Status

()

RESOLVED DUPLICATE of bug 1328218
2 years ago
2 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

({regression})

53 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170102030204

Steps to reproduce:

Open an issue in Jira, example: https://jira.atlassian.com/browse/JRA-17783
I also have the same issue in a locally installed Jira.


Actual results:

No scrollbar appears, so I can only see the first part of the Jira issue.
The menu on the left and on the top does not load.
I cannot add attachments.
A number of JS errors are logged to the console.


Expected results:

It works fine in this and earlier:
http://archive.mozilla.org/pub/firefox/nightly/2016/12/2016-12-20-03-02-15-mozilla-central/firefox-53.0a1.en-US.win64.zip
https://hg.mozilla.org/mozilla-central/rev/567894f026558e6dada617a3998f29aed06ac7d8

It is broken in this and later:
http://archive.mozilla.org/pub/firefox/nightly/2016/12/2016-12-21-03-02-26-mozilla-central/firefox-53.0a1.en-US.win64.zip
https://hg.mozilla.org/mozilla-central/rev/c36fbe84042debef0a5d58b7fc88185b401762ce

JS errors logged in the devtools console:
TypeError: moment is undefined[Learn More]batch.js:213:286
ReferenceError: Calendar is not defined[Learn More]jira.webresources:calendar-en.js:3:1
TypeError: JIRA.API.Projects is undefined[Learn More]batch.js:49:373

It works in Chrome, and no JS errors are reported there (only warnings)
(Reporter)

Updated

2 years ago
Keywords: regression
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1328218
You need to log in before you can comment on or make changes to this bug.