Closed Bug 1328740 Opened 3 years ago Closed 3 years ago

Firefox device permission dialog box is not accessible via keyboard

Categories

(Firefox :: Site Identity, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 53
Tracking Status
firefox52 - verified
firefox-esr52 --- fixed
firefox53 --- verified
firefox54 --- verified

People

(Reporter: rdaware, Assigned: johannh)

References

Details

(Keywords: access, Whiteboard: [fxprivacy])

Attachments

(2 files)

Try getting a Firefox device permission box for microphone or camera. 

Expected Result:
The device permission box is accessible by keyboard controls(Tab,Arrows, Enter)

Actual Result:
The device permission box can be accessed by mouse only.
Component: Device Permissions → Site Identity and Permission Panels
Whiteboard: [fxprivacy] [triage]
Priority: -- → P3
Whiteboard: [fxprivacy] [triage] → [fxprivacy]
This patch makes focusing an anchor icon and pressing space or enter focus the panel. I hope that's sufficient.
Note that by switching panels it was already possible to focus the panel that was switched to, but that wasn't a great situation :)
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Comment on attachment 8828136 [details]
Bug 1328740 - Focus popup notification panels on anchor icon keypress.

https://reviewboard.mozilla.org/r/105638/#review106772

I'm not sure focusing the main button rather than the first focusable element in the panel is perfect, but this is already a very nice improvement, so r+ anyway. Thanks for looking into this! :-)
Attachment #8828136 - Flags: review?(florian) → review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/41914acaabea
Focus popup notification panels on anchor icon keypress. r=florian
Hi Johann,

which version can we expect this change to be in?
Flags: needinfo?(jhofmann)
Hey, once this gets merged into central it will be in 53. That will be Aurora/Developer Edition in a few days.
Flags: needinfo?(jhofmann)
https://hg.mozilla.org/mozilla-central/rev/41914acaabea
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Build ID: 20170131030205
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

Verified as fixed on on Windows 10 x 64, Mac OS X 10.10 and Ubuntu 16.04 x64 on Firefox Nightly 54.0a1.

On Mac OS X 10.11 and Mac OS X 10.12 permission dialog box is not accessible using keyboard. I logged this issue 1335737.

I logged another two issue regarding the device permission box accessibility using keyboard 1335741 and 1335765.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1282938
[Tracking Requested - why for this release]: permission prompts should be keyboard accessible.

Per discussion in bug 1282938 and on IRC in #privacy, it seems like we want to uplift this fix to 52 so that it's in the next ESR.
Flags: needinfo?(jhofmann)
Comment on attachment 8828136 [details]
Bug 1328740 - Focus popup notification panels on anchor icon keypress.

Approval Request Comment
[Feature/Bug causing the regression]: Long ago, this is relevant for 52 because we'd like to fix this a11y issue in ESR
[User impact if declined]: Permission requests are not keyboard accessible which makes web permissions basically a11y-broken
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Show a web permission e.g. on https://permission.site. Focus the urlbar, press Shift + tab. Press space. The permission doorhanger should have focus.
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Small frontend change that focuses the popup on keypress.
[String changes made/needed]: None
Flags: needinfo?(jhofmann)
Attachment #8828136 - Flags: approval-mozilla-beta?
Attachment #8828136 - Flags: approval-mozilla-aurora?
Comment on attachment 8828136 [details]
Bug 1328740 - Focus popup notification panels on anchor icon keypress.

It's been in FF53 already. Aurora53-.
Attachment #8828136 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora-
(In reply to Gerry Chang [:gchang] from comment #13)
> Comment on attachment 8828136 [details]
> Bug 1328740 - Focus popup notification panels on anchor icon keypress.
> 
> It's been in FF53 already. Aurora53-.

Right, sorry, my muscle memory selected both. :)
Comment on attachment 8828136 [details]
Bug 1328740 - Focus popup notification panels on anchor icon keypress.

a11y fix for permission popups, should be in 52.0b7
Attachment #8828136 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Depends on: 1340112
Flagging this for verification, instructions in Comment 12.
Flags: qe-verify+
Reproduced the initial issue using old Nightly from 2017-01-04 under Ubuntu 16.04 32bit, verified that this is no longer reproducible using Firefox 52 beta 8 under Windows 10 64bit and Ubuntu 16.04 32bit.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.