Last Comment Bug 1329016 - CacheIR: Allow -0 (negative zero) index
: CacheIR: Allow -0 (negative zero) index
Status: RESOLVED FIXED
: perf
Product: Core
Classification: Components
Component: JavaScript Engine: JIT (show other bugs)
: unspecified
: Unspecified Unspecified
P3 normal with 1 vote (vote)
: mozilla53
Assigned To: Tom Schuster [:evilpie]
:
: Hannes Verschore [:h4writer]
Mentors:
Depends on:
Blocks: CacheIR jsperf
  Show dependency treegraph
 
Reported: 2017-01-05 13:58 PST by Tom Schuster [:evilpie]
Modified: 2017-01-20 19:05 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Allow negative zero in CacheIR index check (2.14 KB, patch)
2017-01-19 08:43 PST, Tom Schuster [:evilpie]
jdemooij: review+
Details | Diff | Splinter Review

Description User image Tom Schuster [:evilpie] 2017-01-05 13:58:10 PST
Google Docs has IC misses caused by -0. We can truncate those to 0, because ToString(-0) is "0". (Btw we can't do this for strings like "-0", integer exotic objects should even return undefined for this)

We have to communicate this clearly, because if we try to use guardIsInt32 outside of array accesses this is not a valid transformation!
Comment 1 User image Tom Schuster [:evilpie] 2017-01-19 08:43:19 PST
Created attachment 8828387 [details] [diff] [review]
Allow negative zero in CacheIR index check

As you said, fixing bug 1330793 made this trivial.
Comment 2 User image Jan de Mooij [:jandem] 2017-01-19 09:31:40 PST
Comment on attachment 8828387 [details] [diff] [review]
Allow negative zero in CacheIR index check

Review of attachment 8828387 [details] [diff] [review]:
-----------------------------------------------------------------

\o/
Comment 3 User image Pulsebot 2017-01-20 03:44:13 PST
Pushed by evilpies@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/59962d7c3d8c
Allow negative zero in CacheIR index check. r=jandem
Comment 4 User image Phil Ringnalda (:philor) 2017-01-20 19:05:12 PST
https://hg.mozilla.org/mozilla-central/rev/59962d7c3d8c

Note You need to log in before you can comment on or make changes to this bug.