Intermittent dom/media/test/test_seek_out_of_range.html | application crashed [@ mozilla::layers::ImageLayerComposite::~ImageLayerComposite()] after Assertion failure: int32_t(mRefCnt) > 0 (dup release)

RESOLVED DUPLICATE of bug 1329432

Status

()

Core
Graphics: Layers
P3
normal
RESOLVED DUPLICATE of bug 1329432
a year ago
a year ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Priority: -- → P3
Whiteboard: [gfx-noted]

Comment 1

a year ago
(In reply to Treeherder Bug Filer from comment #0)
> Filed by: philringnalda [at] gmail.com
> 
> https://treeherder.mozilla.org/logviewer.html#?job_id=66504221&repo=autoland
> 
> https://archive.mozilla.org/pub/firefox/tinderbox-builds/autoland-win32-
> debug/1483639761/autoland_win7_ix-debug_test-mochitest-media-e10s-bm126-
> tests1-windows-build423.txt.gz

This crash seems like happens not for specific platform. From information in other bugs, the crash happens randomly in any media test. [1] was the link I reproduced on try in other platform.

[1]: https://archive.mozilla.org/pub/firefox/try-builds/vliu@mozilla.com-af9b9c9af3cb56e53e373d47c894e5bd8f180e86/try-macosx64-debug/try_yosemite_r7-debug_test-mochitest-media-e10s-bm132-tests1-macosx-build1533.txt.gz

But after Bug 1329432 was landed, I didn't see any crash happens on ImageContainer Destr. I will set this bug as dup of Bug 1329432. Reopen if the issue still happens.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1329432
You need to log in before you can comment on or make changes to this bug.