Don't Expire Download History So Quickly

RESOLVED DUPLICATE of bug 1324960

Status

()

RESOLVED DUPLICATE of bug 1324960
2 years ago
2 years ago

People

(Reporter: jscher2000, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

I used Firefox a lot...


Actual results:

Downloads older than 60 days were removed from history (per the change to nsPlacesExpiration.js made in bug 1262887).


Expected results:

Considering that downloads are regularly saved all over the hard drive, it is highly inconvenient not to be able to search for them in Firefox history, for as long as other forms of history, or at least much longer than 60 days.

Comment 1

2 years ago
Suggestion: Give the user a choice on how long to keep this data.

Or create an add-on that saves this history to a text file.

Updated

2 years ago
Component: Untriaged → Places
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1324960
You need to log in before you can comment on or make changes to this bug.