mask-position animation out-of-order

RESOLVED FIXED in Firefox 53

Status

()

RESOLVED FIXED
2 years ago
5 months ago

People

(Reporter: u459114, Assigned: u459114)

Tracking

(Blocks: 1 bug)

unspecified
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
While creating test cases for mask-position/mask-size animation, I found this regression.

https://reviewboard.mozilla.org/r/102094/diff/5#index_header
mask-position-after-finish-1b.html failed on all platforms(except linux). The position of mask layer is not updated during animation.
(Assignee)

Updated

2 years ago
Assignee: nobody → cku
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Attachment #8824369 - Flags: review?(mstange)
(Assignee)

Comment 5

2 years ago
Although paint mask on mask layer is landed in 52, we don't need to uplift this patch to 52 since image mask is going to be off after 52 move to release channel.

Comment 6

2 years ago
mozreview-review
Comment on attachment 8824369 [details]
Bug 1329091 - Keep mask style value to determine whether cached mask layer is corrupt.

https://reviewboard.mozilla.org/r/102888/#review103362

Hooray for tests!
Attachment #8824369 - Flags: review?(mstange) → review+

Comment 7

2 years ago
Pushed by cku@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/253205df9e44
Keep mask style value to determine whether cached mask layer is corrupt. r=mstange

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/253205df9e44
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.