Use appendToLocalElement to append source editor

RESOLVED DUPLICATE of bug 1308442

Status

DevTools
Netmonitor
RESOLVED DUPLICATE of bug 1308442
2 years ago
a month ago

People

(Reporter: rickychien, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

netmonitor/shared/components/editor.js is using 

this.deferEditor = this.editor.appendTo(...)

to append source editor with an extra iframe. So we use a deferEditor workaround to tackle iframe editor instance. This workaround can be removed by using appendToLocalElement() instead of appendTo().

The problems with appendToLocalElement are caused by XUL, because document.createElement() call always create XUL on top of netmontor.xul. As a result, here is a followup bug to fix this issue after we eliminate netmonitor.xul

Updated

2 years ago
Flags: qe-verify?
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1308442

Updated

2 years ago
No longer blocks: 1307743
Flags: qe-verify?
Whiteboard: [netmonitor][triage]

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.