DoS using CSS animation and large images

RESOLVED DUPLICATE of bug 1370412

Status

()

Core
ImageLib
P3
normal
RESOLVED DUPLICATE of bug 1370412
a year ago
8 months ago

People

(Reporter: TD, Unassigned)

Tracking

(Depends on: 1 bug)

53 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 affected)

Details

(Whiteboard: gfx-noted, URL)

(Reporter)

Description

a year ago
The site listed (source here: https://github.com/firefox-is-a-good-browser/firefox-is-a-good-browser.github.io) uses a large amount of memory and CPU, which persists when the tab is closed.

The relevant part seems to be the following CSS:

a {
    display: block;
    position: absolute;
    left: 50%;
    top: 50%;
    transform: translate(-50%, -50%);
    animation: a 1s ease-in-out 0s infinite alternate;
    opacity: .99;
    background: #fff url("data:image/jpeg;base64,--ommitted--") center/100% 100%
}

where the jpeg is actually a 10000x10000 png (that displays fine in firefox). My wild guess is that the animation is creating frames faster than layers can consume them, but I haven't looked into it.
This looks to be a very bad case of bug 1243446/bug 1139928.
Component: Layout → ImageLib
Whiteboard: gfx-noted
Depends on: 1243446, 1139928
Priority: -- → P3
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1370412
You need to log in before you can comment on or make changes to this bug.