Intermittent dom/media/test/test_reset_src.html | application crashed [@ nsTArray_Impl<unsigned int, nsTArrayInfallibleAllocator>::Clear]

RESOLVED DUPLICATE of bug 1329432

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1329432
a year ago
a year ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({crash, intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted)

Keywords: crash
https://treeherder.mozilla.org/logviewer.html#?job_id=66917139&repo=mozilla-inbound&lineNumber=4439

ImageContainer crash.
Component: Audio/Video: Playback → Graphics
Whiteboard: gfx-noted

Comment 2

a year ago
nfallibleAllocator>::Clear]
[task 2017-01-06T23:50:15.720752Z] 23:50:15     INFO - Crash dump filename: /tmp/tmpS9y7ZI.mozrunner/minidumps/1667df9d-5342-7376-04472e0c-7226e791.dmp
[task 2017-01-06T23:50:15.720816Z] 23:50:15     INFO - Operating system: Linux
[task 2017-01-06T23:50:15.721397Z] 23:50:15     INFO -                   0.0.0 Linux 3.13.0-100-generic #147-Ubuntu SMP Tue Oct 18 16:48:51 UTC 2016 x86_64
[task 2017-01-06T23:50:15.722198Z] 23:50:15     INFO - CPU: amd64
[task 2017-01-06T23:50:15.722256Z] 23:50:15     INFO -      family 6 model 62 stepping 4
[task 2017-01-06T23:50:15.723332Z] 23:50:15     INFO -      2 CPUs
[task 2017-01-06T23:50:15.724078Z] 23:50:15     INFO - 
[task 2017-01-06T23:50:15.724692Z] 23:50:15     INFO - GPU: UNKNOWN
[task 2017-01-06T23:50:15.725220Z] 23:50:15     INFO - 
[task 2017-01-06T23:50:15.725464Z] 23:50:15     INFO - Crash reason:  SIGSEGV
[task 2017-01-06T23:50:15.725967Z] 23:50:15     INFO - Crash address: 0x0
[task 2017-01-06T23:50:15.726227Z] 23:50:15     INFO - Process uptime: not available
[task 2017-01-06T23:50:15.726908Z] 23:50:15     INFO - 
[task 2017-01-06T23:50:15.727023Z] 23:50:15     INFO - Thread 32 (crashed)
[task 2017-01-06T23:50:15.728061Z] 23:50:15     INFO -  0  libxul.so!nsTArray_Impl<unsigned int, nsTArrayInfallibleAllocator>::Clear [nsTArray-inl.h:ab220a16bda2 : 251 + 0x0]
[task 2017-01-06T23:50:15.728521Z] 23:50:15     INFO -     rax = 0xe5e5e5e5e5e5e5e5   rdx = 0x0000000000000019
[task 2017-01-06T23:50:15.728781Z] 23:50:15     INFO -     rcx = 0x0000000000000003   rbx = 0x00007f59ec92d9e0
[task 2017-01-06T23:50:15.729273Z] 23:50:15     INFO -     rsi = 0x0000000000000000   rdi = 0x00007f59ec92da40
[task 2017-01-06T23:50:15.729486Z] 23:50:15     INFO -     rbp = 0x00007f59f16fe9c0   rsp = 0x00007f59f16fe998
[task 2017-01-06T23:50:15.730145Z] 23:50:15     INFO -      r8 = 0x0000000000000000    r9 = 0x000000000000001d
[task 2017-01-06T23:50:15.730252Z] 23:50:15     INFO -     r10 = 0x00000000e14c8991   r11 = 0x0000000000000206
[task 2017-01-06T23:50:15.731474Z] 23:50:15     INFO -     r12 = 0x00007f59ec92da40   r13 = 0x00007f59f16fea60
[task 2017-01-06T23:50:15.732091Z] 23:50:15     INFO -     r14 = 0x00007f59f2c73ca8   r15 = 0x00007f59ec92d9e0
[task 2017-01-06T23:50:15.732650Z] 23:50:15     INFO -     rip = 0x00007f5a189e42f3
[task 2017-01-06T23:50:15.732726Z] 23:50:15     INFO -     Found by: given as instruction pointer in context
[task 2017-01-06T23:50:15.733263Z] 23:50:15     INFO -  1  libxul.so!mozilla::layers::ImageContainer::~ImageContainer() + 0x25
[task 2017-01-06T23:50:15.733871Z] 23:50:15     INFO -     rbx = 0x00007f59ec92d9e0   rbp = 0x00007f59f16fe9c0
[task 2017-01-06T23:50:15.734312Z] 23:50:15     INFO -     rsp = 0x00007f59f16fe9a0   r12 = 0x00007f59ec92da40
[task 2017-01-06T23:50:15.734746Z] 23:50:15     INFO -     r13 = 0x00007f59f16fea60   r14 = 0x00007f59f2c73ca8
[task 2017-01-06T23:50:15.735198Z] 23:50:15     INFO -     r15 = 0x00007f59ec92d9e0   rip = 0x00007f5a193b7745
[task 2017-01-06T23:50:15.735784Z] 23:50:15     INFO -     Found by: call frame info
[task 2017-01-06T23:50:15.736353Z] 23:50:15     INFO -  2  libxul.so!mozilla::layers::ImageContainer::Release [ImageContainer.h:ab220a16bda2 : 353 + 0x5]
[task 2017-01-06T23:50:15.736936Z] 23:50:15     INFO -     rbx = 0x00007f59ec92d9e0   rbp = 0x00007f59f16fe9f0
[task 2017-01-06T23:50:15.737550Z] 23:50:15     INFO -     rsp = 0x00007f59f16fe9d0   r12 = 0x00007f59f18b0000
[task 2017-01-06T23:50:15.737685Z] 23:50:15     INFO -     r13 = 0x00007f59f16fea60   r14 = 0x00007f59f2c73ca8
[task 2017-01-06T23:50:15.738039Z] 23:50:15     INFO -     r15 = 0x00007f59ec92d9e0   rip = 0x00007f5a18b28a84
[task 2017-01-06T23:50:15.738637Z] 23:50:15     INFO -     Found by: call frame info
[task 2017-01-06T23:50:15.739662Z] 23:50:15     INFO -  3  libxul.so!mozilla::layers::ImageBridgeChild::RecvDidComposite [RefPtr.h:ab220a16bda2 : 40 + 0x8]
[task 2017-01-06T23:50:15.740139Z] 23:50:15     INFO -     rbx = 0x0000000000000000   rbp = 0x00007f59f16fea40
[task 2017-01-06T23:50:15.740845Z] 23:50:15     INFO -     rsp = 0x00007f59f16fea00   r12 = 0x00007f59f18b0000
[task 2017-01-06T23:50:15.741202Z] 23:50:15     INFO -     r13 = 0x00007f59f16fea60   r14 = 0x00007f59f2c73ca8
[task 2017-01-06T23:50:15.741649Z] 23:50:15     INFO -     r15 = 0x00007f59ec92d9e0   rip = 0x00007f5a17068baa
[task 2017-01-06T23:50:15.742524Z] 23:50:15     INFO -     Found by: call frame info
[task 2017-01-06T23:50:15.742773Z] 23:50:15     INFO -  4  libxul.so!mozilla::layers::PImageBridgeChild::OnMessageReceived [PImageBridgeChild.cpp:ab220a16bda2 : 502 + 0x6]
[task 2017-01-06T23:50:15.743294Z] 23:50:15     INFO -     rbx = 0x0000000000000000   rbp = 0x00007f59f16feac0
[task 2017-01-06T23:50:15.743580Z] 23:50:15     INFO -     rsp = 0x00007f59f16fea50   r12 = 0x00007f59e9c70e70
[task 2017-01-06T23:50:15.744427Z] 23:50:15     INFO -     r13 = 0x00007f59f16fea70   r14 = 0x00007f59f16fea60
[task 2017-01-06T23:50:15.746013Z] 23:50:15     INFO -     r15 = 0x00007f59e9c70e78   rip = 0x00007f5a16d0c2a1
[task 2017-01-06T23:50:15.746456Z] 23:50:15     INFO -     Found by: call frame info
[task 2017-01-06T23:50:15.746566Z] 23:50:15     INFO -  5  libxul.so!mozilla::ipc::MessageChannel::DispatchAsyncMessage(IPC::Message const&) + 0x62
[task 2017-01-06T23:50:15.746663Z] 23:50:15     INFO -     rbx = 0x00007f59f18b00e0   rbp = 0x00007f59f16feb00
[task 2017-01-06T23:50:15.746742Z] 23:50:15     INFO -     rsp = 0x00007f59f16fead0   r12 = 0x0000000000000001
[task 2017-01-06T23:50:15.747325Z] 23:50:15     INFO -     r13 = 0x00007f59e9c70e70   r14 = 0x0000000000000000
[task 2017-01-06T23:50:15.747926Z] 23:50:15     INFO -     r15 = 0x0000000000000000   rip = 0x00007f5a18a75282
[task 2017-01-06T23:50:15.747989Z] 23:50:15     INFO -     Found by: call frame info
[task 2017-01-06T23:50:15.748654Z] 23:50:15     INFO -  6  libxul.so + 0xc14ee8
[task 2017-01-06T23:50:15.748774Z] 23:50:15     INFO -     rbx = 0x00007f59f18b00e0   rbp = 0x00007f59f16febb0
[task 2017-01-06T23:50:15.749138Z] 23:50:15     INFO -     rsp = 0x00007f59f16feb10   r12 = 0x00007f59e9c70e70
[task 2017-01-06T23:50:15.749944Z] 23:50:15     INFO -     r13 = 0x0000000000000000   r14 = 0x00007f59f2cc62a0
[task 2017-01-06T23:50:15.750499Z] 23:50:15     INFO -     r15 = 0x00000000ffffffff   rip = 0x00007f5a16c7cee8
[task 2017-01-06T23:50:15.750928Z] 23:50:15     INFO -     Found by: call frame info
[task 2017-01-06T23:50:15.751477

Comment 3

a year ago
Back track in this bug was similar to Bug 1329432 through it happens in different platform with different test case. 

From the comment in [1], this bug might be the regression of Bug 1325784 as well.



[1]: https://bugzilla.mozilla.org/show_bug.cgi?id=1329432#c2
See Also: → bug 1329432
It seems dup of bug 1329432. It seems double delete of ImageContainer like bug 1329432 Comment 3.

Comment 5

a year ago
(In reply to Sotaro Ikeda [:sotaro] from comment #4)
> It seems dup of bug 1329432. It seems double delete of ImageContainer like
> bug 1329432 Comment 3.

I will set this bug as dup of bug 1329432. Reopen if anyone doesn't agree it.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1329432
You need to log in before you can comment on or make changes to this bug.