Last Comment Bug 1329430 - after removing zoom control from toolbar it should appear in menu
: after removing zoom control from toolbar it should appear in menu
Status: RESOLVED INVALID
:
Product: Firefox
Classification: Client Software
Component: Toolbars and Customization (show other bugs)
: 51 Branch
: x86_64 Windows 10
-- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: :Gijs (away until Feb 27)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-07 08:41 PST by Roshan Dawande
Modified: 2017-01-25 07:47 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Roshan Dawande 2017-01-07 08:41:25 PST
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

1. Launch Firefox with a clean profile
2. Verify there is nothing in the Location Bar related to zooming
3. Click the Menu [≡] 
4. Click the [+] Customize button 
5. Click anywhere on the zoom controls and drag them to the Toolbar 
6. Click the [√] Exit Customize button and verify the Zoom Controls still function in the toolbar 
7. Verify there is nothing in the Location Bar related to zooming 
8. Remove the Zoom Controls from the toolbar and ensure default value is 100% when clicking the Menu [≡]


Actual results:

In the step 8, After removing zoom controls from the toolbar we have to check the default value is 100% But,
NO ZOOM CONTROLS ARE VISIBLE IN THE MENU.


Expected results:

Zoom controls should be visible in the menu with default value 100%.
Comment 1 User image Emil Pasca [:emilpasca] 2017-01-11 04:21:16 PST
User Agent:  Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

I have tested this issue on Windows 10 x64 with the latest Firefox release (50.1.0) and the latest Nightly (53.0a1-20170110075905) and managed to reproduce it.
In the step 8, after removing zoom controls from the toolbar, when check to see if the default value is 100% in the menu, the zooming controls are missing. 

This seems to be more of an enhancement than an issue in my opinion. 
However, I am assigning a component to this issue in order to involve the development team and get an opinion on this.
Comment 2 User image :Gijs (away until Feb 27) 2017-01-25 07:47:10 PST
(In reply to Roshan Dawande from comment #0)
> 8. Remove the Zoom Controls from the toolbar and ensure default value is
> 100% when clicking the Menu [≡]
> 
> 
> Actual results:
> 
> In the step 8, After removing zoom controls from the toolbar we have to
> check the default value is 100% But,
> NO ZOOM CONTROLS ARE VISIBLE IN THE MENU.

If you want the zoom controls to be in the menu, use "Move to menu" rather than "remove from toolbar".

Note You need to log in before you can comment on or make changes to this bug.