Closed Bug 1329446 Opened 3 years ago Closed 3 years ago

Find in page function is broken

Categories

(Toolkit :: Find Toolbar, defect, major)

53 Branch
x86
Windows 10
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla53
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 + verified

People

(Reporter: alice0775, Assigned: jchen)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]: Find in page function is broken

Reproducible: always

Steps to Reproduce:
1. Open https://tweakers.net/
2. Open FindBar
3. Type word
   --- observe, 
        AR: number of match is 1 , highlights is only one.
        ER: number of match should be 3, highlights should be 3(one is emphsized, the other two are highlighted).
4. Click on Find next
   ---  observe,
        AR: nothing happens
        ER: should find next matching
5. Click on Find previous
   ---  observe,
        AR, ER: successfully find previous matching

Actual Results:
 Number of match is wrong
 Highlight all does not work
 Find next does not work

Expected Results:
 Should work properly.


Regression Window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5b9702d8fe4e8ddf3ce155e81d54b9d199805843&tochange=d506d3c193c90dc85d57519f8d822c3919b12322
Flags: needinfo?(nchen)
Can we disable the feature in nightly and enable it once we fixed all the remaining important known issues?
FYI,
The problem also occurs if set findbar.modalHighlight =fasle.
Sylvestre, Alice, this is not caused by feature work; I think you might be confused with bug 1291278.

This is caused by bug 1319660!
Tracking 53+ for this visible regression.
I'll work on it in bug 1319660
Flags: needinfo?(nchen)
Duplicate of this bug: 1330077
Any news on this ? Search is still unusable on Nightly since 11 days :(
Flags: needinfo?(nchen)
Bug 1319660 is getting backed out. Should make it to tomorrow's nightly.
Flags: needinfo?(nchen)
Bug 1319660 has been backed out. Should be in tomorrow's nightly.
Assignee: nobody → nchen
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Duplicate of this bug: 1332449
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID:20170221004019

Verified fixed using the latest Aurora 53.0a2 (2017-02-21) and latest Nightly 54.0a1 (2017-02-21) on Ubuntu 16.04, Mac OS X 10.11 and Windows 10 x64.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.