Closed Bug 1329570 Opened 5 years ago Closed 5 years ago

Crash in mozilla::dom::Location::GetPathname

Categories

(Core :: Networking, defect)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- fixed

People

(Reporter: n.nethercote, Assigned: emk)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-4ad4e41c-f480-43d3-a7b2-de3d52170107.
=============================================================

New crash, first showed up in Nightly 20161231030203. Regression window is here:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6f63f95e28ffc05c0d2f5ef6cd6e05905fe8ea5a&tochange=81463aec62d02fa1915e03cda7a8ddc8d44c71fc

which includes bug 1323683, which touched GetPathname().

emk, can you please investigate?
Flags: needinfo?(VYV03354)
Oops, thanks for catching.
Flags: needinfo?(VYV03354)
Thank you for the fast fix!
Comment on attachment 8824897 [details]
Bug 1329570 - Restore missing error check in mozilla::dom::Location::GetPathname. .gosu

https://reviewboard.mozilla.org/r/103232/#review103752
Attachment #8824897 - Flags: review?(valentin.gosu) → review+
Pushed by VYV03354@nifty.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/d4446c207c13
Restore missing error check in mozilla::dom::Location::GetPathname. r=valentin.gosu
https://hg.mozilla.org/mozilla-central/rev/d4446c207c13
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Duplicate of this bug: 1329225
You need to log in before you can comment on or make changes to this bug.