Closed Bug 1329724 Opened 3 years ago Closed 3 years ago

In Reply empty lines below cut off quote in email body disappear

Categories

(MailNews Core :: Backend, defect)

Unspecified
All
defect
Not set

Tracking

(thunderbird52 fixed, thunderbird53 fixed)

VERIFIED FIXED
Thunderbird 53.0
Tracking Status
thunderbird52 --- fixed
thunderbird53 --- fixed

People

(Reporter: RainerBielefeldNG, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

User Story

Wrong copy paste in original report. Should be "Steps how to reproduce with Server-Installation ..."
Steps how to reproduce  NOT reproducible REPRODUCIBLE with Server-Installation of  unofficial (by FRG) en-US SeaMonkey 2.50a1 (NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0 Build 20161219235428  (Default Classic Theme) on German WIN7 64bit:

0. Preferences: Cite automatically, Start my reply below quote, compose
   as plain text
1. In Newsgroup thread select a posting in Thread pane
2. Click [Reply]
   » Composer opens with cited text
3. Click into the middle of the quote
4. With mouse select text until end
6. <Backspace> for deletion of end of quotation
7. 2 times <Enter> for 1 Empty line below Quot
8. Start own text with "Hello ..."
9. Send
10. Check Copy in sent folder and your posting in NG:
    Bug: empty line above "Hello ..." is missing

a) you see an example at <mozilla.test>, 
   "Empty lines disappear" by Rainer Bielefeld, 
   19:47 +0100,
   Message-ID: <TKudnQcu5LvhRe7FnZ2dnUU7-emdnZ2d@mozilla.org>
b) in Tread with posting Posting of
        RainerBielefeld_nurNG@bielefeldundbuss.de
        19:23 +0100
        "[SM 2.46] Leerzeilen verschwinden beim Antworten"
        Message-ID: <o50keg$5pt$1@gioia.aioe.org>
   it's told that that also happens with SM 2.46
c) in same thread it's told that also other empty lines
   (empty paragraphs) sometimes disappear, STR appreciated!
d) in the same thread it's told that that happens with WIN10 and Linux
   so NEW + OS=All
g) With exact STR from original report tests in thread from (b) showed that this
   bug is not reproducible with 2.46
   (Subject: "Re: [SM 2.46] Leerzeilen verschwinden beim Antworten - Bug 1329724 not reproducible"
h) As you see an example at <mozilla.test>, 
   "Empty lines disappear" by Rainer Bielefeld, 
   Mon, 9 Jan 2017 21:50:17 +0100
   Message-ID: <9fqdnWbYgbEXau7FnZ2dnUU7-bednZ2d@mozilla.org>
   this issue also is reproducible with TB Daily 53.0a1 (2016-12-23) (64-bit)
Some additional tests at <mozilla.test> show:

i1) Already reproducible with SM 2.49a2 Build 20170108183831
i2) Not (yet) reproducible with SM 2.48 Build 20170108184343

k) not related to 64Bit-build
Keywords: regression
Summary: Empty lines in email body disappear → Empty lines below cut off quote in email body disappear
Version: SeaMonkey 2.50 Branch → SeaMonkey 2.49 Branch
Summary: Empty lines below cut off quote in email body disappear → In Reply empty lines below cut off quote in email body disappear
h): Product and so on due to Comment 3
Also REPRODUCIBLE with Server-Installation of  official  en-US SeaMonkey 2.50a1 (NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0 Build 20170110004313  (Default Classic Theme) on German WIN7 64bit

I hope related TB for SM 2.49 is TB 52?
User Story: (updated)
Component: MailNews: General → Backend
Product: SeaMonkey → MailNews Core
Version: SeaMonkey 2.49 Branch → 52
I can reproduce this, but you don't need six comments to explain the problem :-(

Do it like this:
Answer a short BMO mail in plaintext mode. Click in the middle of the mail, select to the end, delete selection. Hit <enter> once to get to the next line after the quoted text, then again to produce an empty line. Type something and send. Result: Empty line gone in the sent result.

This sadly is another regression from bug 1288911. Basically, the quote is now presented in a <span> with "display: block;". Check it with ThunderHTMLedit. After the STR above you get:

<body style="font-family: -moz-fixed; white-space: pre-wrap; width: 72ch;">
<div class="moz-cite-prefix">On 11/01/2017 16:47, Bugzilla@Mozilla wrote:<br></div>
<span style="white-space: pre-wrap; display: block; width: 98vw;">&gt; https://bugzilla.mozilla.org/show_bug.cgi?id=1329795<br>&gt; <br>&gt; --- Comment #2 from Richard Marti (:Paenglab) &lt;richard.marti@gmail.com&gt; 2017-01-11 16:47:42 CET ---<br>&gt; Yes, there's other issues on Sierra.</span><br>jkjk<br><br></body>

So the end of the span, since it's displayed as block, causes a visible break, and with another break, you create an empty line. So on the screen I see:

===
...
> Yes, there's other issues on Sierra.

jkjk
====

However, copying this to - say Notepad++ - already loses the empty line and so does sending since the visual effect of "display: block" is not taken into account.

Matters are actually worse. If you only hit <enter> once and write in the line below the quote, your answer will be joined to the quote.
This looks like an M-C Core::Editor bug to me. When hitting <enter>, a <br> should have been inserted into the <span>. I'm working on getting this reproduced in a <div contenteditable> in Firefox, but it's harder than I thought.
Depends on: 1330796
This needs to be fixed in the Mail Editor in Core::Editor.

I'll leave this bug open for uplifts to various versions of TB.
Fixed by bug 1330796 in mozilla53 for TB 53. To fix TB 52, uplift to mozilla52 has been requested already. Watch the tracking flags here.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 53.0
Uplift has been done, this should now work in Earlybird TB 52.
I did a test with unzipped installer of  official  en-US SeaMonkey 2.52a1 (NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0 Build 20170406002917  (Default Classic Theme) on German WIN7 64bit: No longer reproducible with STR in original report.

Test on mozilla.test mobil_info@bielefeldundbuss.de, "Re: Empty lines disappear", Date: Sun, 9 Apr 2017 18:32:19 +0200
Status: RESOLVED → VERIFIED
Blocks: 1354931
You need to log in before you can comment on or make changes to this bug.