Closed Bug 1330074 Opened 5 years ago Closed 5 years ago

Enable no-self-assign, no-useless-call and no-useless-return in devtools/

Categories

(DevTools :: General, enhancement, P3)

enhancement

Tracking

(firefox53 fixed)

RESOLVED FIXED
Firefox 53
Tracking Status
firefox53 --- fixed

People

(Reporter: ntim, Assigned: ntim)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

No description provided.
no-labels is already enabled in devtools, so that the label related rules are redundant.
Summary: Enable no-extra-label, no-self-assign, no-unused-labels, no-useless-call and no-useless-return in devtools/ → Enable no-self-assign, no-useless-call and no-useless-return in devtools/
Severity: normal → enhancement
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Priority: -- → P3
Comment on attachment 8825539 [details]
Bug 1330074 - Enable no-self-assign, no-useless-call and no-useless-return in devtools/.

https://reviewboard.mozilla.org/r/103664/#review104644

Thanks!  Overall it seems like a good change, but I'd like to know more about the task one.

::: devtools/shared/task.js:161
(Diff revision 3)
>     *
>     * @return A promise object where you can register completion callbacks to be
>     *         called when the task terminates.
>     */
>    spawn: function (task) {
> -    return createAsyncFunction(task).call(undefined);
> +    return createAsyncFunction(task)();

Hmm, can we double check this one?  What will be the this value now?
Attachment #8825539 - Flags: review?(jryans)
Comment on attachment 8825539 [details]
Bug 1330074 - Enable no-self-assign, no-useless-call and no-useless-return in devtools/.

https://reviewboard.mozilla.org/r/103664/#review104644

> Hmm, can we double check this one?  What will be the this value now?

Looks like it should be the same, according to ESLint docs.
Comment on attachment 8825539 [details]
Bug 1330074 - Enable no-self-assign, no-useless-call and no-useless-return in devtools/.

https://reviewboard.mozilla.org/r/103664/#review104664
Attachment #8825539 - Flags: review+
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/7795164d8206
Enable no-self-assign, no-useless-call and no-useless-return in devtools/. r=jryans
Patch landed few hours ago https://hg.mozilla.org/mozilla-central/rev/7795164d8206
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.