Closed Bug 1330076 Opened 3 years ago Closed 3 years ago

Rewrite test_chrome_ext_shutdown_cleanup.html into an xpcshell test

Categories

(WebExtensions :: General, defect)

defect
Not set

Tracking

(firefox53 fixed)

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: rpl, Assigned: rpl)

References

Details

(Whiteboard: triaged)

Attachments

(1 file)

The goal of this issue is rewriting the toolkit/components/extensions/test/mochitest/test_chrome_ext_shutdown_cleanup.html into an xpcshell.

One reason for doing so is related to Bug 1308271 which is going to ship a WebExtension as a system addon and it breaks this test because the GlobalManager is always initialized when this test runs.

Converting this test into an xpcshell should prevent this failure because the new xpcshell test will not run in an environment with any preinstalled system addon (and as a nice side-effect, this test will run faster).
Attachment #8825565 - Flags: review?(aswan)
Blocks: 1308271
Assignee: nobody → lgreco
I can confirm that this test fixes the issues we have in bug 1308271. Thank you very much! :)
Comment on attachment 8825565 [details]
Bug 1330076 - Rewrite test_chrome_ext_shutdown_cleanup.html into an xpcshell test

https://reviewboard.mozilla.org/r/103690/#review104626
Attachment #8825565 - Flags: review?(aswan) → review+
Autoland couldn't rebase this for landing.
Keywords: checkin-needed
(In reply to Ryan VanderMeulen [:RyanVM] from comment #5)
> Autoland couldn't rebase this for landing.

My apologies for that.

Patch rebased (with the small conflict resolved).
Whiteboard: triaged
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/b04953cd621e
Rewrite test_chrome_ext_shutdown_cleanup.html into an xpcshell test r=aswan
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/b04953cd621e
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.