BeOS: Printer is not recognized

ASSIGNED
Assigned to

Status

Core Graveyard
Widget: BeOS
P1
major
ASSIGNED
16 years ago
4 years ago

People

(Reporter: Jack Burton, Assigned: Paul)

Tracking

({regression, relnote, smoketest})

Trunk
Future
x86
BeOS
regression, relnote, smoketest
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:0.9.9) Gecko/20020312
BuildID:    2002031218

When I launch a print preview or a print, Mozilla says I got no priter, while I
GOT one.


Reproducible: Always
Steps to Reproduce:
1.Start Mozilla
2.Click on Printer icon


Actual Results:  Mozilla says: "There was a problem printing: no printer could
be found"

Expected Results:  It should have printed.

Printing DID work in Mozilla 0.98

Comment 1

16 years ago
I don't have BeOS, so I can't test it. As a troubleshooting step, though, could
you try reinstalling your printer?
Keywords: regression
(Reporter)

Comment 2

16 years ago
Just tried. It didn't help.

Updated

16 years ago
Keywords: qawanted

Comment 3

16 years ago
Boris, any ideas?
Nope, sorry.  I have no printer set up on _any_ OS (I just print to file).
(Assignee)

Comment 5

16 years ago
Printing is not implemented "yet" under BeOS
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

16 years ago
Fine. But in Mozilla 0.98 I COULD start a print preview. Now I can't.

Updated

16 years ago
Keywords: qawanted → mozilla1.0.1
(Assignee)

Comment 7

16 years ago
Good point.  Plus, you should be allowed to print to a file (ps), which you could do before.  I had not tried this under 0.9.9.  The postscript code is still being compiled under BeOS, so it seems that maybe this is a problem.  I believe under *nix, a default "lpr" printer always exists, which is why this problem would not arrise there.  

So, the Bug is that even though a printer does not exist, you should still be allowed to print/preview, since you can print to a file, but, mozilla won't allow you to, since, there is no printer defined.

Comment 8

16 years ago
Someone needs to implement the nsIPrinterEnumerator on BeOS, at least make it do
the same thing as GTK for PS
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → Future
(Assignee)

Comment 9

16 years ago
I'll do it some time this week.  Taking assignment.
Assignee: rods → arougthopher
Status: ASSIGNED → NEW
(Assignee)

Comment 10

16 years ago
Created attachment 81822 [details] [diff] [review]
gets postscript "working" again, allows for print preview

This will get the postscript printer building into the global printer list
under BeOS.  Mainly it was no longer in the Makefile.in.  But, I also cleaned
up some code to get ready for native printing.	The XPrint stuff can be and
will be removed before final patch is ready, since, well, we will never print
from mozilla under X11 under BeOS :)

Question, the postscript code was crashing under BeOS, unless I made the
included change.  I don't know how this works on other platforms, unless the
PRUint32 is mapped to something non-primitive.	Any ideas?
(Assignee)

Comment 11

16 years ago
well, the above patch no longer works, or applies cleanly.  There were some
problems, according to the bonsai logs, on 5/7/02, that required changes to some
of the code that the above patch affected.  I will post a new patch sometime soon.

Comment 12

16 years ago
this seems interesting for 1.0.1. however, the bug is futured. if we get
traction for this in the 1.0.1 milestone, please re-nominate.
Keywords: mozilla1.0.1 → mozilla1.0.1-

Comment 13

16 years ago
hit in smoketests. I'll look into this afterwards.

Note: I couldn't close the ok dialog that told me there were no printers. Which 
means I died. 

Relnote: Printing in BeOS is not implemented. Whomever generates the package 
for BeOS should probably disable the print menuitems. I'll try to remember to 
make a patch for that too.
Keywords: relnote, smoketest
QA Contact: sujay → timeless
(Assignee)

Comment 14

16 years ago
I have been working on this, in my spare time.  Currently, the work I have is broken, due 
to other changes that were made.  If I get a chance, I try to work on this some more, to at 
least be able to print postscript, though, I was having problems getting the ps library 
built.

Updated

16 years ago
Keywords: mozilla1.1
(Assignee)

Updated

16 years ago
Depends on: 148692
(Assignee)

Comment 15

16 years ago
*** Bug 172143 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
*** Bug 187337 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
*** Bug 188292 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
I think I have the same problem on Solaris 1.3b (2003021104)

("There was a problem printing.  No printer could be found", and "Printing
failed...", which didn't happen in 1.1)
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 19

15 years ago
Will look into this again, once Bug#218134 is commited
Depends on: 218134

Comment 20

15 years ago
Paul, i have feeling that timeless was submitted quite big patch (though, very
preliminary) too. But name of that bug imho was quite mystical, so i cannot find
it immediately. But maybe i'm wrong.

Updated

15 years ago
Blocks: 103890

Comment 21

15 years ago
I am having the same problem with Solaris 2.8 and Mozilla 1.4:

Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4) Gecko/20030701

I was definitely able to print in one of the Solaris 2.6
builds I downloaded sometime in June 2003.

I was wondering if it's just a matter of setting the proper
environment variables?

Comment 22

15 years ago
I have a $50 reward for whoever gets printing to work in BeOS.
Follow the link for details.
http://bezilla.org/modules.php?op=modload&name=Forum&file=viewtopic&topic=100&forum=2

Comment 23

15 years ago
Adding "BeOS" to the summary.

Chris, you might want to find a more reliable host for your bounty than
bezilla.org - the site seems to be dead at the moment.

Prog.
Summary: Printer is not recognized → BeOS: Printer is not recognized

Comment 24

15 years ago
bezilla.org seems to be working fine to me, but i'll go ahead and post the whole
thing here as well.

I have 50 US dollars ready to send via paypal to whoever gives the BeOS port of
mozilla the ability to print to an actual printer (printing to a file doesn't
count).

If anyone wants to commit additional reward dollars, please post here. If you
have any other kind of comment, please post here. I am also announcing this in
the BeOSJournal forums, but i'd like to keep everything in one place. 

In order to qualify for the reward, someone must provide me with a working build
for BeOS 5.0 Intel (net_server). I have a fully supported HP LaserJet attached
to my machine that I will test with. Output must be similar to what one would
get by printing a webpage with mozilla under a different OS. You can't just
print any old mess and call it a success.

Comment 25

14 years ago
Since I first posted my printing reward (almost 7 months ago), a lot has
happened in the BeOS world.  But no one has stepped forward with a solution to
this problem.  So I would like to revise my proposal:
The reward has now been quadrupled from $50 to $200.  The rest of the proposal
remains the same as in comment number 24 (except the bezilla.org part葉hey seem
to be down for the count).
(In reply to comment #24)
> If anyone wants to commit additional reward dollars, please post here.

I will contribute USD100 towards this cause.

Koki
QA Contact: timeless → printing

Updated

4 years ago
Component: Printing: Output → Widget: BeOS
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.