Closed Bug 1330316 Opened 5 years ago Closed 5 years ago

Not possible to clone someone else's bugs using a BMO account with minimal permissions

Categories

(bugzilla.mozilla.org :: User Interface, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Fanolian+BMO, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170111030235

Steps to reproduce:

1. Have a BMO account with minimal permissions. (I don't know what permissions I have. It is just a common BMO account)
2. Find a bug that the reporter is not yourself. (Quick link to you: this bug :) )
3. Scroll to bottom. Click "New/Clone Bug". Select one of the following:
  A) … in this product
  B) … in this component
  C) … that blocks this bug
  D) … that depends on this bug
  E) … as a clone of this bug


Actual results:

As for case C/D/E, an error page with such message appears:
>Sorry, either the product _undefined_ does not exist or you aren't authorized to enter a bug into it.

As for case A/B, a page stating:
> Enter A Bug
> Product: undefined:
appears before redirecting me back to the enter_bug.cgi?format=guided.


Expected results:

I should be able to clone a bug with relevant fields prefilled.

Note:
1. I don't know if step 1 is necessary to reproduce this issue but a common BMO account is all I have. And I think such operations had been tested (with a more privileged account).
2. I can clone a bug if the reporter is myself. (At least no error pages are shown.)
Screenshot of the said error message when I click "… that blocks this bug" in Bug 1330884.
It is fixed as at 2017-03-02.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Component: User Interface: Modal → User Interface
You need to log in before you can comment on or make changes to this bug.