Devtools stop working when pressing F12 twice to open them

RESOLVED DUPLICATE of bug 1328004

Status

DevTools
General
RESOLVED DUPLICATE of bug 1328004
2 years ago
12 days ago

People

(Reporter: jdescottes, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8826109 [details]
broken_startup_when_pressing_shortcut_twice.gif

STRs are a bit racy, sorry. 
I can repro quite consistently on OSX and Win 7, and it seems to be a nightly-only issue:

- open devtools with F12 (or cmd+I)
- press F12 (or cmd+I) before the tools are finished loading

AR: tools are broken, can no longer be closed/opened. 
ER: tools should either close, or the second F12 should be ignored
Here is the stack trace of the crash:

> TypeError: this.inspector is null
> Stack trace:
> _getPageStyle@chrome://devtools/content/inspector/inspector.js:290:5
> Inspector.prototype.init<@chrome://devtools/content/inspector/inspector.js:130:11
> _run@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:311:39
> process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:917:23
> walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:801:7
> Promise*scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:734:11
> schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:765:7
> completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:702:7
> onPacket/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/protocol.js:1329:9
> DevTools RDP*request@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/protocol.js:1269:14
> generateRequestMethods/</frontProto[name]@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/protocol.js:1426:14
> initCssProperties<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/fronts/css-properties.js:237:16
> _run@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:311:39
> TaskImpl@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:273:3
> asyncFunction@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:247:14
> Inspector.prototype.init<@chrome://devtools/content/inspector/inspector.js:127:33
> _run@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:311:39
> TaskImpl@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:273:3
> asyncFunction@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:247:14
> open@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/inspector/panel.js:12:12
> onLoad@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/framework/toolbox.js:1437:19
I think it is rather a duplicated of bug 1328004. But correct me if I'm wrong.
Your patch from bug 1328004 fixes this for me as well. Thanks! Quite possible the race was only made more visible by 1245921
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1328004

Updated

12 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.