hide the `Object` keyword when showing cookies object

VERIFIED FIXED in Firefox 53

Status

defect
P1
normal
VERIFIED FIXED
3 years ago
Last year

People

(Reporter: gasolin, Assigned: gasolin)

Tracking

(Blocks 1 bug)

unspecified
Firefox 53
Dependency tree / graph

Firefox Tracking Flags

(firefox53 verified)

Details

(Whiteboard: [netmonitor])

Attachments

(1 attachment)

from bug 1317649,

when there are other cookies properties besides 'name', 'value', the request and response cookies shows as Object Rep (show `Object` keyword instead of cookie value, and show all properties in sub list)

We should display cookie value instead of `Object` keyword. It can be done by customize the rendering using `renderValue` per (callback) in properties-view(TreeView) component
Iteration: --- → 53.5 - Jan 23
Flags: qe-verify?
Priority: -- → P1
Hi Fred, should this bug be set to 'qe-verify+' or 'qe-verify-'
Flags: needinfo?(gasolin)
It will change UI so its qe-verify+
Flags: needinfo?(gasolin)
Flags: qe-verify? → qe-verify+
QA Contact: ciprian.georgiu
As discussed in daily meeting, the PR hide the `Object` string for cookies object Rep, and not trying to mimic the original UI. (For the record the origin cookies object tree usage is buggy. When user tap the value after object, the value is selectable but the toggle sign and sub tree are disappeared.) Now we keep the consistent treeview usage without disturbing info (`Object` string is meaningless for cookies).

I put the logic in `properties-view` to not duplicate the `renderValueWithRep` method in CookiesPanel. Since for all sidebar panels we pretty sure the case (member.value is an object and there is a `member.value.value` property) is only happened in Cookies panel
Summary: customize the tree view to display cookie value instead of `Object` keyword → hide the `Object` keyword when showing cookies object
Comment on attachment 8827316 [details]
Bug 1330858 - Hide Object string for cookies object;

https://reviewboard.mozilla.org/r/105038/#review105918

Works for me, thanks Fred.

R+ assuming try is green.

Honza
Attachment #8827316 - Flags: review?(odvarko) → review+
try green (with unrelated webconsole intermittent), thanks
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d9380dbe4177
Hide Object string for cookies object;r=Honza
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d9380dbe4177
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
I've managed to reproduce this issue on a Nightly build from (2017-01-12).
This is verified fixed on latest Aurora 53.0a2 (2017-01-25) on the following OSes:
- Windows 10 x64
- Mac OS 10.11.6
- Ubuntu 16.04 x64 LTS
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.