Closed Bug 1331007 Opened 3 years ago Closed 3 years ago

The debug filter button state isn't store in the prefs for the new console

Categories

(DevTools :: Console, defect, P1)

50 Branch
defect

Tracking

(firefox54 verified)

VERIFIED FIXED
Firefox 54
Iteration:
54.1 - Feb 6
Tracking Status
firefox54 --- verified

People

(Reporter: nchevobbe, Assigned: jdescottes)

References

Details

Attachments

(1 file)

STR : 
- Open the new console, 
- Open the filter bar
- Toggle off the debug button.
- Close the console
- Open the console again

ER : The debug button is still off
AR : The debug button is back on
Flags: qe-verify+
Priority: -- → P2
QA Contact: iulia.cristescu
Whiteboard: [new-console]
Priority: P2 → P1
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Iteration: --- → 54.1 - Feb 6
Comment on attachment 8833021 [details]
Bug 1331007 - fix console debug filter persistence;

https://reviewboard.mozilla.org/r/109264/#review110408

Sounds good !
Attachment #8833021 - Flags: review?(chevobbe.nicolas) → review+
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1b1fc1efce0e
fix console debug filter persistence;r=nchevobbe
https://hg.mozilla.org/mozilla-central/rev/1b1fc1efce0e
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Reproduced the issue on 53.0a1 (2017-01-23). This is verified fixed on 54.0a1 (2017-02-09), using Windows 10 x64, Mac OS X 10.11 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Whiteboard: [new-console]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.