Gear icon in about:addons page moves 1px down on click

VERIFIED FIXED in Firefox 53

Status

()

Toolkit
Add-ons Manager
P5
normal
VERIFIED FIXED
5 months ago
2 months ago

People

(Reporter: Towkir, Assigned: kevin.kwong.chip, Mentored)

Tracking

({good-first-bug})

Trunk
mozilla54
good-first-bug
Points:
---

Firefox Tracking Flags

(firefox53 verified, firefox54 verified)

Details

(Whiteboard: triaged)

Attachments

(2 attachments)

(Reporter)

Description

5 months ago
Created attachment 8826829 [details]
gear_icon_moves_down.gif

I am not sure about the component here.
Just got to about:addons and navigate to 'Extensions' from the left navigation.

STR:
Now click on the gear icon at the right top corner of the page just before the search bar.

RESULT:
See if the result is similar to the attachment.

EXPECTION:
Definitely not what happened. it should stay still.

Updated

5 months ago
Component: Theme → Add-ons Manager
Product: Firefox → Toolkit

Updated

5 months ago
Keywords: good-first-bug
Priority: -- → P5
Whiteboard: triaged
(Reporter)

Comment 1

5 months ago
Can you mentor this one ? 
Any specific guidelines/steps for a fix ?

Thanks
Flags: needinfo?(sescalante)

Comment 2

5 months ago
The element in question is here:

https://dxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/content/extensions.xul#224

Which means its influenced by CSS applied to (among other things) `header-utils-btn`, you can see all the places that's referenced here:

https://dxr.mozilla.org/mozilla-central/search?q=header-utils-btn&redirect=true

For example:

https://dxr.mozilla.org/mozilla-central/source/toolkit/themes/shared/extensions/extensions.inc.css#252

So its likely you'll need to adjust the CSS in one of those files to fix the 1px jump.

I'm not sure if you've built Firefox before or not, if not the best place to start is here: 

http://areweeveryoneyet.org/onramp/desktop.html

... and follow the instructions from there.

If you have any more questions please feel free to ping me and I'll see if I can help.
Mentor: amckay@mozilla.com
Flags: needinfo?(sescalante)
(Assignee)

Comment 3

4 months ago
Hi is anyone assigned to this bug? can I take this and work on it as my good-first-big?
(Reporter)

Comment 4

4 months ago
Hi Kevin,
Thanks for your interest. Follow comment 2 , attach a patch to this bug. Someone will then assign this on you.
Flag Needinfo to the mentor if you need anything specific.

Thanks
(Assignee)

Comment 5

4 months ago
Created attachment 8838891 [details] [diff] [review]
kevin-proposed-change.patch

Hi, so i'm actually having some trouble pushing the changes that I have committed locally to MozReview, but this attachment shows what I have changed to prevent the button from moving down when it is clicked on my system.

If I can get more time to configure my hgrc files and stuff then hopefully I can push the code change to MozReview
Flags: needinfo?(amckay)

Comment 6

4 months ago
I couldn't reproduce this on OS X, but I could on Windows and this patch fixes it for me. I'll set the bug for review for a peer. So you know for your next patch, you need to do this before check-in is allowed.
Flags: needinfo?(amckay)

Updated

4 months ago
Attachment #8838891 - Flags: review?(rhelmer)
Attachment #8838891 - Flags: review?(rhelmer) → review+

Comment 7

4 months ago
Thanks rhelmer, kevin I've just checkin-needed for you so the sheriffs will pick it up and take it from here. When you do your next bug, you can do that yourself :)
Keywords: checkin-needed
(Assignee)

Comment 8

4 months ago
(In reply to Andy McKay [:andym] from comment #7)
> Thanks rhelmer, kevin I've just checkin-needed for you so the sheriffs will
> pick it up and take it from here. When you do your next bug, you can do that
> yourself :)

Alright thanks Andy, for future reference can you elaborate what steps I would need to do to check in the code myself?
Flags: needinfo?(amckay)

Comment 9

4 months ago
To check in code for yourself you need to get level three access, the levels are discussed here:

https://www.mozilla.org/en-US/about/governance/policies/commit/access-policy/

Next step for most contributors is level one access so you can run tests on the mozilla testing infrastructure.
Flags: needinfo?(amckay)
Assignee: nobody → kevin.kwong.chip

Comment 10

4 months ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fc1415794974
Reset the padding on top and button to 0 to prevent the button from moving when clicked. r=rhelmer
Keywords: checkin-needed

Comment 11

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/fc1415794974
Status: NEW → RESOLVED
Last Resolved: 4 months ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
QA Whiteboard: [good first verify]

Comment 12

2 months ago
I have reproduced this issue nightly 53.0a1 (2017-01-14) (64-bit)

This bug is now verified as fixed in latest beta 54.0b1 (64-bit)

Build ID 	20170420011827
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

[bugday-20170419]
I have reproduced this bug with Nightly 53.0a1 (2017-01-13) (64-bit) on Ubuntu 16.04 (64  Bit)! 

This bug's fix is now verified with latest Beta 54.0b2!

Build ID   : 20170424215451
User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0

[bugday-20170426]

Comment 14

2 months ago
[testday-20170428] 
The issue is no longer reproducible in Firefox Beta 53.0/32-bits in Build ID:20170413192749 in Windows 10.0 X 64-bit.
status-firefox53: affected → fixed

Updated

2 months ago
status-firefox53: fixed → verified
Marking as verified based on above comments.
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify] → [good first verify][testday-20170428]
status-firefox54: fixed → verified
You need to log in before you can comment on or make changes to this bug.