Closed Bug 1331363 Opened 3 years ago Closed 3 years ago

segfault with gcc-6.3 on startup

Categories

(Core :: DOM: Core & HTML, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1312344

People

(Reporter: budek, Unassigned)

Details

firefox-50.1 segfaults in nsTextFragment::SetTo() (dom/base/nsTextFragment.cpp)
at
...
memcpy(m2b, aBuffer, m2bSize.value());
...
where m2bSize.value() has odd values, e.g. 2 * 16052973 (aLength = 16052973)
The values are differed at each retry.

An initialisation of mTextLength in dom/xml/nsXMLContentSink.cpp:

nsXMLContentSink::nsXMLContentSink()
  : mPrettyPrintXML(true), mTextLength(0)
{
}

seems to work.
Doesn't look like GCC6 is supported yet (bug 1316555), though this particular issue is fixed in Fx52.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1312344
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.