Remove about:newaddon when new sideloading flow is in place

RESOLVED FIXED in Firefox 61

Status

()

defect
P2
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: aswan, Assigned: aswan)

Tracking

51 Branch
mozilla61
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox61 fixed)

Details

(Whiteboard: triaged)

Attachments

(1 attachment)

Assignee

Description

2 years ago
Once bug 1317363 is done, we'll have a new flow in place for sideloaded add-ons.  There are a few other things that need to be done before we turn on the new flow by default (tracked in bug 1308292) but once that is done, the old code for about:newaddon should be removed.
Assignee

Updated

2 years ago
Depends on: webext-permissions
Priority: -- → P2
Whiteboard: triaged

Updated

2 years ago
Duplicate of this bug: 1392770

Comment 2

a year ago
(In reply to Andrew Swan [:aswan] from comment #0)
> Once bug 1317363 is done, we'll have a new flow in place for sideloaded
> add-ons.  There are a few other things that need to be done before we turn
> on the new flow by default (tracked in bug 1308292) but once that is done,
> the old code for about:newaddon should be removed.

All of these bugs are closed - can we remove this now? :-)
Flags: needinfo?(aswan)
Assignee

Comment 3

a year ago
Yep, I believe this is good to go as soon as somebody has the time to do it.
Flags: needinfo?(aswan)
Assignee

Updated

a year ago
Assignee: nobody → aswan
Comment hidden (mozreview-request)
Assignee

Updated

a year ago
Attachment #8968368 - Flags: review?(kmaglione+bmo)

Comment 5

a year ago
mozreview-review
Comment on attachment 8968368 [details]
Bug 1331521 Remove about:newaddon

https://reviewboard.mozilla.org/r/237052/#review242860

\o/
Attachment #8968368 - Flags: review?(kmaglione+bmo) → review+
https://hg.mozilla.org/mozilla-central/rev/c85fefa9248c
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61

Comment 9

a year ago
Is manual testing required on this bug? If yes, please provide some STR and the proper extension(if required) or set the “qe-verify -“ flag.

Thanks!
Flags: needinfo?(aswan)
Assignee

Updated

a year ago
Flags: needinfo?(aswan) → qe-verify-
You need to log in before you can comment on or make changes to this bug.