If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

stylo: Get the proper viewport size for viewport units evaluation

RESOLVED DUPLICATE of bug 1303229

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 1303229
8 months ago
7 months ago

People

(Reporter: emilio, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
We use to pass a fake viewport size to the cascade() function. That's used for viewport units.

With the work in bug 1331213, the missing piece for this is a binding function that takes it from the pres context.

Note we need to take into account scrollbars on some cases, so we should do something similar to what CalcViewportUnitsScale[1] does, checking it's thread safe.

[1]: http://searchfox.org/mozilla-central/rev/c477aa8bd99278962998adba1c5e4b15a02c42c7/layout/style/nsRuleNode.cpp#398
(Reporter)

Comment 1

8 months ago
Sorry, I don't know how to write, sigh.
Summary: stylo: Get the proper viewport size for media query evaluation → stylo: Get the proper viewport size for viewport units evaluation
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1303229
You need to log in before you can comment on or make changes to this bug.