CSS colors of table uncorrectly displayed

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: NetVicious, Assigned: karnaze)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
See the web.


This style isn't displayed correctly.

td.bgtitulo             {
        padding:1px;
        background-color: #000000;
        border-color: #C0C0C0 #C0C0C0 #FFFF00 #C0C0C0;
}

The page has passed HTML 4.01 and CSS Level 2 tests from w3.org
->HTML Tables

I'm not quite sure what the problem is; is it that the left and right sides of
the "heading" (with black background) have gray borders, rather than yellow?
Assignee: asa → karnaze
Component: Browser-General → HTMLTables
QA Contact: doronr → amar
(Reporter)

Comment 2

17 years ago
Yes. All the borders need to be gray, but the central line it's yellow

/-------------\
|             |
|-y-e-l-l-o-w-|
|             |
|             |
\-------------/
um.. you have "border-collapse: collapse"

Then you set a gray border on the top cell and a yellow border on the bottom
cell (the class="bgcontenido") one.  Since the two cells share the border
between them (collapsed border model) we have to pick the color to paint that
border in.  We just pick the color from the lower cell, since that paints later
(and that's a perfectly reasonable choice in those circumstances).  You should
just turn off the border-top on the .bgcontenido cells.

Marking invalid, since the rendering is correct as far as I can tell.  But if
I've missed something, please reopen the bug and say what that is...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.