Closed Bug 1331637 Opened 3 years ago Closed 3 years ago

DnD uploads empty folders on onedrive.com

Categories

(Core :: DOM: Drag & Drop, defect)

51 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1336091
Tracking Status
firefox50 --- wontfix
firefox51 --- affected
firefox52 --- affected
firefox53 --- affected

People

(Reporter: petruta.rasa, Unassigned)

References

Details

(Keywords: site-compat)

[Affected versions]:
- Firefox 50.1RC
- Firefox 51RC
- Aurora 52.0a2 2017-01-17
- Nightly 53.0a1 2017-01-17

[Affected platforms]:
- Win 10 64-bit
- Mac OS X 10.11
- Ubuntu 16.04 x64

[Steps to reproduce]:
1. Login to https://onedrive.com
2. Drag and drop a directory, that contains other directories and several files, in the main view on onedrive to upload it

[Expected result]:
- All files are uploaded

[Actual result]:
- Empty folders are uploaded (containing 0 files)

[Regression range]:
- This is not a regression, it didn't work also on 50.0a1 Nightly 2016-08-02 (after bug 1288683 and bug 1289254 landed)

[Additional notes]:
- https://www.drive.google.com/ and https://www.dropbox.com/ support folder DnD
Is this different than 1330979?
Flags: needinfo?(petruta.rasa)
Yes, bug 1330797 was a regression in which no files or folders could be dragged to onedrive.com.

This issue is not a regression and it only affects the files within folders, which are not uploaded.
Flags: needinfo?(petruta.rasa)
Keywords: site-compat
Is this something to do with webkitdirectory?
Flags: needinfo?(amarchesini)
baku looked and thinks this may be DnD-related. Michael, can you take a look?
Flags: needinfo?(amarchesini) → needinfo?(michael)
I've looked into this more, and I have found a difference between our and chrome's implementation which may be breaking onedrive due to string comparisons.

https://wicg.github.io/entries-api/#relative-path states that the relative path of a file should not start with a `/` character. This matches chrome's behavior, however our implementation includes that leading slash. I believe that onedrive uses a string comparison with the low part of the path to determine which directory to upload a file into (or something along those lines - following minified code in a debugger is tricksy). 

Baku, how hard would it be to write a patch which doesn't include that leading slash, so we can check if it fixes the problem? (Even if it doesn't fix the problem, we probably want that patch for spec compliance).
Flags: needinfo?(michael) → needinfo?(amarchesini)
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1336091
You need to log in before you can comment on or make changes to this bug.