When I move the browser window the drop down doesn't work correctly

NEW
Unassigned

Status

()

Toolkit
Autocomplete
P3
normal
9 months ago
5 months ago

People

(Reporter: Ovidiu, Unassigned)

Tracking

Trunk
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox51 unaffected, firefox52 wontfix, firefox53 affected, firefox54 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
Created attachment 8827495 [details]
Move the browser window bug.mp4

[OS:]
Mac OS 

[Versions tested upon:]
52.0a1 2017-01-17
53.0a1 2017-01-17

[Description:]

Steps:

1. Open Firefox and go to imgur.com
2. Create 2 users entries 
3. Go to https://imgur.com/signin (the drop down appears)
4. Click outside the browser window 
5. Move the browser window

[Actual Result:]

The drop down remains behind. 

[Expected Result:]
 
The drop down should follow input field. 

I was able to reproduce this only on Mac OS. Please see the attached video.
(Reporter)

Updated

9 months ago
OS: Unspecified → Mac OS X
CCing Neil since he worked on a similar bug recently.

Comment 2

9 months ago
I don't see this myself, but from the video it looks like the popup is disappearing correctly then reappearing. This could be something specific to the form autocomplete. I notice you have a custom cursor effect though; are you using a regular mouse/trackpad?
(Reporter)

Comment 3

9 months ago
Did you try with a Mac? I use a logitech mouse (a normal mouse) and I don't have any custom cursor effect.

Comment 4

9 months ago
Please test this on Firefox 51.  This may be an existing bug rather than a regression.
status-firefox51: --- → ?
Flags: needinfo?(ovidiu.boca)
(Reporter)

Comment 5

9 months ago
With 51 release I can't reproduce this because the dropdown doesn't appear when you focus the page, only if you click on username field. On 52.0b1 beta I can reproduce this.
status-firefox51: ? → unaffected
status-firefox54: --- → affected
Flags: needinfo?(ovidiu.boca)

Comment 6

9 months ago
Moving this to XUL Widget, since its not a password manager specific issue.

Neil, can you take a look at this?
Component: Password Manager → XUL Widgets
Flags: needinfo?(enndeakin)

Comment 7

9 months ago
Since I can't reproduce it, I can't really do anything about it. But as I said, it looks specific to the password autocomplete.
Component: XUL Widgets → Autocomplete
Flags: needinfo?(enndeakin)
Too late for firefox 52, mass-wontfix.
status-firefox52: affected → wontfix

Updated

5 months ago
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.