Closed Bug 1331706 Opened 3 years ago Closed 3 years ago

Consider making vsync non-prioritized in Aurora

Categories

(Core :: Graphics, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox51 --- unaffected
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: smaug, Assigned: smaug)

References

Details

Attachments

(1 file)

Our animation code is too slow (bug 1322970) and looks like we have some other slow (and otherwise buggy, based on the leak) code too (bug 1329079) and those bugs possibly can't be fixed in Aurora
Attachment #8827585 - Flags: review?(wmccloskey)
Attachment #8827585 - Flags: review?(wmccloskey) → review+
Depends on: 1332226
Comment on attachment 8827585 [details] [diff] [review]
non_prio_vsync.diff

Approval Request Comment
[Feature/Bug causing the regression]: bug 1306591 
[User impact if declined]: slowly behaving web pages in some case
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: this is disabling a feature causing regressions
[Needs manual test from QE? If yes, steps to reproduce]: See the blocking bugs and test cases in them
[List of other uplifts needed for the feature/fix]: NA
[Is the change risky?]: not
[Why is the change risky/not risky?]: we're just reverting back to the old behavior
[String changes made/needed]: NA
Attachment #8827585 - Flags: approval-mozilla-aurora?
Another testcase https://jsfiddle.net/va5vpxLz/1/
Comment on attachment 8827585 [details] [diff] [review]
non_prio_vsync.diff

no priority for vsync event, aurora52+
Attachment #8827585 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Hmm, I thought I had landed this to m-i too, since I want this to the next aurora.
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2cded9d87d13
Make vsync non-prioritized for now. r=billm
Sorry if this way of landing causes any problems.


I'll back this out from m-i once I have good plan for bug 1332226 .
No longer blocks: 1340142
You need to log in before you can comment on or make changes to this bug.