Closed Bug 1331839 Opened 3 years ago Closed 3 years ago

Intermittent dom/media/test/test_mediarecorder_bitrate.html | seek-short.webm encoded@1000000=6380 > encoded@100000=6041

Categories

(Core :: Audio/Video: Recording, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox52 --- unaffected
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: pehrsons)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Andreas - fallout from some of your changes?
Rank: 23
Component: Audio/Video → Audio/Video: Recording
Priority: -- → P2
Probably.
Assignee: nobody → pehrson
I saw this locally once and it looked like the two encoders were fed different number of frames.

I also think this test relies on async tracks (i.e., they're not available on mozCaptureStream() but notified about later by MediaStreamGraph). I'll try to harden it as a first step.
Status: NEW → ASSIGNED
Comment on attachment 8829850 [details]
Bug 1331839 - Harden test_mediarecorder_bitrate.html.

https://reviewboard.mozilla.org/r/106836/#review108104
Attachment #8829850 - Flags: review?(jwwang) → review+
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/3c9618fb43d3
Harden test_mediarecorder_bitrate.html. r=jwwang
Looks like it worked. Please also uplift this testonly patch to aurora and beta.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: leave-open
Resolution: --- → FIXED
Whiteboard: [checkin-needed-aurora][checkin-needed-beta]
Target Milestone: --- → mozilla54
Duplicate of this bug: 1307330
Whiteboard: [checkin-needed-aurora][checkin-needed-beta] → [checkin-needed-beta]
Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.