Closed Bug 1331865 Opened 3 years ago Closed 1 year ago

history.go(0) doesn't behave the same as location.reload()

Categories

(Core :: DOM: Navigation, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1484849

People

(Reporter: freesamael, Unassigned)

Details

Demo: http://post-n-reload.herokuapp.com/

history.go(0) won't prompt for resending post request, while location.reload() does. According to the spec [1] they should behave the same.

I'm thinking if we should override loadtype to LOAD_RELOAD_NORMAL in nsDocShell::LoadURI if loadtype was LOAD_HISTORY and mOSHE == shentry.

[1] https://html.spec.whatwg.org/#dom-history-go
Summary: history.go(0) doesn't prompt for resending POST request → history.go(0) doesn't behave the same as location.reload()
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1484849
You need to log in before you can comment on or make changes to this bug.