The completion popup panel is not auto-dismissed by clicking outside of it

VERIFIED FIXED in Firefox 53

Status

()

P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: simona.marcu, Assigned: johannh)

Tracking

53 Branch
Firefox 53
Points:
---

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53 verified)

Details

(Whiteboard: [fxprivacy])

Attachments

(2 attachments)

Comment hidden (empty)
Created attachment 8827886 [details]
popupCompletion.mp4

[Affected versions]:
- Nightly 53.0a1

[Affected platforms]:
- All 

[Steps to reproduce]:
1. Install an unverified add-on, you can choose the fist .xpi from:
https://ftp.mozilla.org/pub/labs/fxdt-adapters/win32/
2. After the completion popup panel is displayed, dismiss it by clicking outside the panel

[Expected result]:
- The panel is dismissed 

[Actual result]:
- The panel is not dismissed. Please see the screen-cast.
Blocks: 1315236
status-firefox50: --- → unaffected
status-firefox51: --- → unaffected
status-firefox52: --- → unaffected
Summary: The completion popup notification can't be dismissed → The completion popup panel is not auto-dismissed by clicking outside of it
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1331917
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1331916
(Assignee)

Updated

2 years ago
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Whiteboard: [fxprivacy] [triage]
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Comment 6

2 years ago
I'm not sure if this needs tests and I wouldn't be sure where to put them. If you think it does, feel free to r-

Comment 7

2 years ago
mozreview-review
Comment on attachment 8828252 [details]
Bug 1331918 - Make addon install failure messages non-persistent.

https://reviewboard.mozilla.org/r/105724/#review106628

r=me with the removal of the hunk below or a clarification about its necessity.

::: toolkit/modules/PopupNotifications.jsm:1034
(Diff revision 2)
> +      if (notificationsToShow.some(n => n.options.persistent)) {
> +        this.panel.setAttribute("noautohide", "true");
> +      } else {
> +        this.panel.removeAttribute("noautohide");
> +      }
> +

Why is this necessary? We are calling _showPanel() right above this block, which will eventually run the same code and race with this, since it runs after the _hidePanel() promise has been fulfilled.
Attachment #8828252 - Flags: review?(past) → review+
Priority: -- → P1
Whiteboard: [fxprivacy] [triage] → [fxprivacy]
Comment hidden (mozreview-request)
(Assignee)

Comment 9

2 years ago
Yes, you're right, actually _showPanel() is the much better place to put this. I had to do this since on already open panels with updated notifications the noautohide attribute is not updated according to the new panel's specifications. So if you have a persistent panel that becomes a non-persistent one, it would still be incorrectly persistent.

But yeah, that was definitely the wrong place.

Comment 10

2 years ago
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/61dfd2f2ae3d
Make addon install failure messages non-persistent. r=past

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/61dfd2f2ae3d
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox53: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Verified as fixed using the latest Aurora 53.0a2 (Build ID: 20170202084301)and the latest Nightly 54.0a1 (Build ID: 20170202030211) on Windows 10 x64, Ubuntu 16.04 x64 and Mac OS X 10.11.
Status: RESOLVED → VERIFIED
status-firefox53: fixed → verified
You need to log in before you can comment on or make changes to this bug.