Closed Bug 1331995 Opened 3 years ago Closed 3 years ago

[RTL] On some occasions, the URL on the URL bar disappears

Categories

(Firefox for Android :: Theme and Visual Design, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 54
Tracking Status
firefox54 --- verified

People

(Reporter: itiel_yn8, Assigned: maliu)

References

(Blocks 1 open bug)

Details

(Keywords: push-needed, rtl)

Attachments

(2 files)

STR #1:
1. Install Nightly, Hebrew locale
2. Enter random webpages
3. Open a New Tab -> History
4. Click any of the items there
5. While Nightly loads the page, observe the URL bar

AR for STR #1:
The URL bar is empty, and only after the page finishes to load, the URL is shown

ER for STR #1:
The URL should be shown also when loading the page


STR #2:
* This STR may not be accurate but it seems to always work for me.
1. Install Nightly, Hebrew locale
2. Open www.google.com
3. Click the back button
4. Observe the URL bar

AR for STR #2:
The URL bar is empty, and a side effect is bug 1322144

ER for STR #2:
The URL should be shown

Note: it seems this bug is reproducible also on Ioana's Pixel Android 7.1.1 device, see attachment 8827972 [details].
Assignee: nobody → max
Status: NEW → ASSIGNED
Comment on attachment 8842294 [details]
Bug 1331995 - Reset text direction to locale in order to reveal text hint,

https://reviewboard.mozilla.org/r/116160/#review117736

::: mobile/android/base/java/org/mozilla/gecko/toolbar/ToolbarDisplayLayout.java:248
(Diff revision 1)
>      }
>  
>      void setTitle(CharSequence title) {
>          mTitle.setText(title);
>  
> +        if(TextUtils.isEmpty(title)) {

nit: space after if.
Attachment #8842294 - Flags: review?(s.kaspari) → review+
Comment on attachment 8842294 [details]
Bug 1331995 - Reset text direction to locale in order to reveal text hint,

https://reviewboard.mozilla.org/r/116160/#review117756
Pushed by max@mxli.us:
https://hg.mozilla.org/integration/autoland/rev/c6a264b47ece
Reset text direction to locale in order to reveal text hint, r=sebastian
Comment on attachment 8842393 [details] [diff] [review]
Bug 1331995 - Reset text direction to locale in order to reveal text hint, checkstyle,

https://reviewboard.mozilla.org/r/116260/#review117808
Attachment #8842393 - Flags: review?(s.kaspari) → review+
Comment on attachment 8842393 [details] [diff] [review]
Bug 1331995 - Reset text direction to locale in order to reveal text hint, checkstyle,

https://reviewboard.mozilla.org/r/116260/#review117810
Attachment #8842393 - Attachment is patch: true
Attachment #8842393 - Attachment mime type: text/x-review-board-request → text/plain
Keywords: push-needed
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/32524eee28c5
Reset text direction to locale in order to reveal text hint, checkstyle, r=sebastian
https://hg.mozilla.org/mozilla-central/rev/c6a264b47ece
https://hg.mozilla.org/mozilla-central/rev/32524eee28c5
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
I'm unable to reproduce the issue since the last few days, so this seems fixed to me.
verified by comment 12
Status: RESOLVED → VERIFIED
Device: Nexus 6 (Android 7.0)
Build: 54.0b4

I've also verified this issue and the URL bar was behaving as expected. Tried multiple scenarios and I was not able to reproduce the issue anymore.
You need to log in before you can comment on or make changes to this bug.