Closed Bug 1332053 Opened 3 years ago Closed 9 months ago

Device forgotten after switching out then back into responsive design mode

Categories

(DevTools :: Responsive Design Mode, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: milan, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rdm-v2])

Toggle into responsive design mode.
Select a device (e.g., iPhone 6s)
Toggle out of responsive design mode
The device selection is gone.

This is a change that came with responsive design mode UI refresh. If it was meant to be done that way, I'd like to argue that it's wrong :), and if it wasn't meant to be changed, it's a bug.
At the moment, nothing is saved, so everything reverts back to defaults on next open.

We don't want it to be that way though!  Bug 1248619 intends to add a general restore mechanism so everything will be as you left it.
Depends on: 1248619
Priority: -- → P2
Whiteboard: [rdm-v2]
This should be covered by Bug 1248619 - Save / restore RDM workspace when toggling.
Just to clarify, I don't consider this bug to be blocked by Bug 1248619, but rather it is a subset and therefore a duplicate of Bug 1248619.
You may be right, but we could choose to solve this subset first or in a different way, so it's useful to keep this bug around.
I don't mind if this is tagged as a duplicate or not, whatever makes it easier to track.

By the way, I stopped using this feature once the size memory was gone.  Most of my (spare time :) work is on a weird resolution window-display size, and I can never remember it, and it takes me five minutes to dig it up :)  It's unfortunate we had to ship this feature without this functionality.  Hopefully it comes back quickly, I'm sure I'm not alone :)
(In reply to Milan Sreckovic [:milan] from comment #5)
> By the way, I stopped using this feature once the size memory was gone. 
> Most of my (spare time :) work is on a weird resolution window-display size,
> and I can never remember it, and it takes me five minutes to dig it up :) 
> It's unfortunate we had to ship this feature without this functionality. 
> Hopefully it comes back quickly, I'm sure I'm not alone :)

We recently added the ability to create custom devices in new RDM, so you could use that to store the device size (custom devices remain in place across RDM sessions).  The current device selection (this bug) still gets reset, but you'd be able to choose your custom specially sized device from the menu in future sessions.

Here's a post about the feature:

https://discourse.mozilla-community.org/t/adding-custom-devices-in-responsive-design-mode/13552
Product: Firefox → DevTools
Blocks: rdm-toggle

This was fixed in bug 1248619

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.