Some minidumps cannot be loaded in VS, showing "xul.dll not found"

RESOLVED FIXED in Firefox 53

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kanru, Assigned: ted)

Tracking

Trunk
mozilla54
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed, firefox54 fixed)

Details

Attachments

(1 attachment)

I was trying to load some minidumps for bug 1325258 but found some minidumps cannot be loaded in VS successfully.

For example the minidump from bp-447ac0fc-664a-4227-9242-4e2fe2170117 is good but the minidump from bp-1a85eb8a-3c57-45ba-b1f6-e1f772170117 is broken.

I'm not sure if this is a symbol server issue or we changed the way we generate symbols for symbol server. If this is not the correct component, please correct me.
Flags: needinfo?(ted)
This is a regression from bug 1329320, sorry. I did test it locally but apparently not thoroughly enough. I added a bunch of tests to the Rust crate and I believe it works interoperably with the Microsoft implementation now:
https://github.com/luser/rust-makecab/commit/d2bc6797648b7a834782714a55d339d2fd4e58c8

I'll update the in-tree binaries which should fix this.
Assignee: nobody → ted
Blocks: 1329320
Flags: needinfo?(ted)
Comment on attachment 8830020 [details]
bug 1332147 - update makecab to a newer version.

https://reviewboard.mozilla.org/r/106960/#review108310
Attachment #8830020 - Flags: review?(mshal) → review+
We should uplift this to Aurora as well since bug 1329320 was merged there.
Pushed by tmielczarek@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ceeff94945e0
update makecab to a newer version. r=mshal
https://hg.mozilla.org/mozilla-central/rev/ceeff94945e0
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
I picked an arbitrary Nightly crash:
https://crash-stats.mozilla.com/report/index/6c908570-8dd2-4afe-aa60-d7b422170208#tab-details

Downloaded the minidump, opened it in MSVC, and verified that I was able to debug it without issues.
Component: Symbols → Breakpad Integration
Product: Socorro → Toolkit
Target Milestone: --- → mozilla54
Version: unspecified → Trunk
Comment on attachment 8830020 [details]
bug 1332147 - update makecab to a newer version.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1329320
[User impact if declined]: Debugging minidumps from crash-stats on Windows is more difficult for developers. They may need to download the matching build instead of the debugger automatically fetching the files from the symbol server.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: The code in question here is only used for compressing PDB and EXE/DLL files for upload to the symbol server, which are only provided for use by developers using a debugger. That's already somewhat broken on Aurora so it can't get much more broken, and it has zero impact on the product or crash reporting.
[String changes made/needed]: None
Attachment #8830020 - Flags: approval-mozilla-aurora?
Comment on attachment 8830020 [details]
bug 1332147 - update makecab to a newer version.

This can help debug crash. Aurora53+.
Attachment #8830020 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.