Uninstalling a 64-bit build does not automatically remove the maintenance service

VERIFIED FIXED in Firefox 53

Status

()

P3
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: mhowell, Assigned: mhowell)

Tracking

Trunk
Firefox 54
x86_64
Windows
Points:
---

Firefox Tracking Flags

(firefox50 wontfix, firefox51 wontfix, firefox52 wontfix, firefox53 verified, firefox54 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
When uninstalling a product which can use the Mozilla Maintenance Service to perform application updates, the uninstaller checks to see if it is the only application on the system which is registered with the service. If so, it also runs the maintenance service uninstaller. This does not appear to work if that application is a 64-bit build.

The cause is probably that the wrong registry view is set when reading the path to the maintenance service uninstaller, since those uninstall entries are written in the 32-bit view (i.e., WOW6432Node), but other maintenance service keys are written in the native view.
(Assignee)

Comment 1

2 years ago
I don't think this is serious enough to block 64-bit rollout (bug 797208), since few users would ever notice it and it doesn't do any real harm.
Priority: -- → P3
Assignee: nobody → mhowell
status-firefox50: --- → wontfix
status-firefox51: --- → affected
status-firefox52: --- → affected
OS: Unspecified → Windows
Hardware: Unspecified → x86_64
Comment hidden (mozreview-request)
Comment on attachment 8828959 [details]
Bug 1332496 - Fix 64-bit uninstaller failing to automatically remove maintenance service;

https://reviewboard.mozilla.org/r/106188/#review108112

::: browser/installer/windows/nsis/maintenanceservice_installer.nsi:194
(Diff revision 1)
>    WriteUninstaller "$INSTDIR\Uninstall.exe"
> +
> +  ; Since the Maintenance service can be installed either x86 or x64,
> +  ; always use the 64-bit registry.
> +  ${If} ${RunningX64}
> +    SetRegView 64

I don't see any cleanup for 64 bit systems that have the uninstall string written to the 32 bit registry. How is this handled?

Clearing review for the answer to this.
Comment on attachment 8828959 [details]
Bug 1332496 - Fix 64-bit uninstaller failing to automatically remove maintenance service;

https://reviewboard.mozilla.org/r/106188/#review108114
Attachment #8828959 - Flags: review?(robert.strong.bugs)
Comment hidden (mozreview-request)
status-firefox51: affected → wontfix
status-firefox54: --- → affected
Comment on attachment 8828959 [details]
Bug 1332496 - Fix 64-bit uninstaller failing to automatically remove maintenance service;

https://reviewboard.mozilla.org/r/106188/#review109680
Attachment #8828959 - Flags: review?(robert.strong.bugs) → review+

Comment 7

2 years ago
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7f00eae7c948
Fix 64-bit uninstaller failing to automatically remove maintenance service; r=rstrong

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7f00eae7c948
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox54: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
(Assignee)

Comment 9

2 years ago
Comment on attachment 8828959 [details]
Bug 1332496 - Fix 64-bit uninstaller failing to automatically remove maintenance service;

Approval Request Comment
[Feature/Bug causing the regression]:
Bug 797208 (which landed in 53) made this a problem for many more users by making 64-bit installs the default, but this bug has probably always been present in 64-bit Windows builds.

[User impact if declined]:
Additional steps needed to completely uninstall Firefox beyond running the Firefox uninstaller.

[Is this code covered by automated tests?]:
No.

[Has the fix been verified in Nightly?]:
Yes.

[Needs manual test from QE? If yes, steps to reproduce]: 
No, I've tested it manually myself using an official Nightly build.

[List of other uplifts needed for the feature/fix]:
None.

[Is the change risky?]:
No.

[Why is the change risky/not risky?]:
It's a small and straightforward change, and doesn't affect any browser functionality, only the uninstaller.

[String changes made/needed]:
None
Attachment #8828959 - Flags: approval-mozilla-aurora?
Comment on attachment 8828959 [details]
Bug 1332496 - Fix 64-bit uninstaller failing to automatically remove maintenance service;

Since this problem was exacerbated in 53 let's uplift to aurora.
Attachment #8828959 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 11

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/ba5398b3f6fc
status-firefox53: affected → fixed
status-firefox52: affected → wontfix
Flagging this for manual testing on Fx53.
Flags: qe-verify+
I reproduced the issue on 53.0a2 (2017-02-01). The bug is verified fixed on 53.0b1 build1 (20170307064827), using Windows 10 x64. Also, based on comment 9, the bug is verified fixed for the 54 build, too.
Status: RESOLVED → VERIFIED
status-firefox53: fixed → verified
status-firefox54: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.