Audio continues after tab closed

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
P1
normal
RESOLVED WORKSFORME
a year ago
9 months ago

People

(Reporter: walkingfish10, Unassigned)

Tracking

50 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

Begin playing a video on one site e.g. Youtube
Start a second video in a new tab on a different site e.g. CNN
Open a new blank tab, close the second and then the first tab.


Actual results:

Audio from the tabs continue playing


Expected results:

Audio stops when it's source tab is closed
(Reporter)

Updated

a year ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Updated

a year ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
This used to happen to me all the time a couple of years ago. Are you able to reproduce it consistently?

Comment 2

11 months ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #1)
> This used to happen to me all the time a couple of years ago. Are you able
> to reproduce it consistently?

I've been seeing this bug for the first time in recent weeks, but unfortunately I don't have a method to consistently reproduce this bug yet.

Comment 3

11 months ago
actually I think I've found a more reliable way to reproduce the bug. When opening a video in Private Browsing, adding additional tabs, and then closing the tab containing the video, the audio from the video continues in the background despite the tab being closed. This also happens in normal (non-private) sessions, but at seemingly random times.
I'm hoping that the STR will help resolve this issue.
Priority: -- → P1

Comment 5

9 months ago
I cannot reproduce this issue both in provate browsing and non-private browsing.

I thought this might be related to bug 1344357, which leaks a window and the videos under it. 
However, it seems not, the audio stops when the leaked tab is closed in bug 1344357.
Per comment 5, 
I am going to close it. Please feel free to reopen it if everyone still can see it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.